Problem with quick search

Hi all, it took me a long time before posting, but I can’t find the problem so I seek for help. First, we just migrated to suitecrm and the install is fresh new, and I have already performed the data import.

I got a big problem with quick search. I want to make quicksearch field find all the object that match the patern i write.

I have already used the wildcard in front option in config_override.

I finally found a hint: It works for some modules, but not for all. Like it worked to find users to assign, but don’t work for account or contacts. and that’s the thing we use the most (90% of the time),so it’s really bad if it doesn’t work.
An other problem I have with that is quick search always auto-complete really fast, some time before we even finished writing.

If someone can help me find out where does that come from, it will be really really great.

If you need any information i will try to respond as quick as possible.

Thank you for reading.

Sorry for my english, i did my best =)

The fast auto-complete is a problem with your browser, not SuiteCRM, if I’m not mistaken.

Did you configure your cron jobs? You should start by checking if they are running. The search function depends on a couple of jobs called “Lucene Index” and “AOD Optimize” or some similar names.


And if you have problems please provide all your versions (OS, Database, Web server, PHP, SuiteCRM) so we can better help you.

Ok i found a solution that fixed my problem. Its a bit wierd so might be looking at by the suitecrm team.

The module did not update after i told it to wildcard. It worked for popup, for quick create, but not for the modules creation view.

The only way i found to make it update, is to make a change to the view, and save and publish it. That way the module kinda force rebuild and took into account my changes.

I let the answer here it might help some one in the same situation as I.

So its fixed and works great now ^^

Perhaps a Quick Repair and Rebuild would have helped. It’s always worth trying whenever your system is acting in unexpected ways.

Anyway I’m glad you solved it.

When i said i did all i could, it included that and remove my cache and all the things i could ever think that could help ^^. But yeah solved so all good now.