Problem with modules search box


I have a problem with the search box. As an example, in calls, it finds all the records if I don’t specify any search parameter. If I specify ANY parameter at all, the result of the search is empty…

Any ideas?

I have version 7.7.7 with afresh install, and I uploaded a set of records from an old instance of SugarCRM 6.5.16.

I’m getting crazy…

set your logs in debug mode and check what’s happening at the moment you click “search”

best regards

when I do that, there is a huge amount of information in the log… what should I look for precisely?


This is a known bug with 7.7.7

You can fix this by replacing include/SearchForm/SearchForm2.php with the file from 7.7.6 or simply wait for the next release which should take care of this issue.


Does anyone have a download link to the 7.7.6 installer?

@blloyd all releases

best regards


Perfect, that worked a treat @till

Thanks for the link @mikebeck, searches are now returning results correctly as promised.

Thank you, it worked like a charm!