Problem with database name


My hosting provider uses database names that starts with a figure. No way to change that.

This gives me the following error during install.

Warning: mysqli_query() expects parameter 1 to be mysqli, boolean given in /storage/content/42/102842/ on line 135 
Please fix the following errors before proceeding:

Database name cannot begin with a number, '#', or '@' and cannot contain a space, '"', "'", '*', '/', '\', '?', ':', '<', '>', '&', '!', or '-' 
The provided database host, username, and/or password is invalid, and a connection to the database could not be established. Please enter a valid host, username and password 
Unable to check database version. 
* Required field


Is there a work around for this?


My experience is that using SuiteCRM on a shared host, like “HostGator” for example, doesn’t work out very one. Issues arise, like the one you just mentioned, or email sending limitations, or ssh/telnet access, or cron job limitations, or … I did get it working OK as a test instance, but I didn’t keep it as a production instance.

Services like Amazon AWS are really affordable options for hosting this in the cloud. Mine costs about $10/mo for the instance and about $10/mo for the storage of backups. Performance is great for my 10 users on the micro instance.

To make things even easier, you can deploy your instance and manage backups using