Problem with Calendar

I hope this problem was not discussed already. I have looked but did not find anything.

When I try and create a meeting in full form mode or enter a contract I get this error:

Fatal error: Call to a member function format() on a non-object in /public_html/SuiteCRM/modules/vCals/vCal.php on line 137

Also, if I try and create a meeting in the popup window by clicking on a date, I get a small popup after clicking save that says “Error saving”

That file is set to 775 currently. I temporarily have all files set to 775 just to work out any bugs.

Hi there,

We recommend the following permissions are set on your SuiteCRM instance:

sudo chown -R www-data:www-data .

sudo chmod -R 755 .

sudo chmod -R 775 cache custom modules themes data upload config_override.php



Why am I receiving the error though?

Have you set these recommended permissions? Are you still receiving the errors?

I am on a shared hosting plan so I am unable to run the script you told me. I used filezilla to set the permissions of all the files to 755. Then I set the listed folders and the one file to 775. I only set the folders, not the contents, to 775. Is that correct? I am still having the error message after completing the above steps.

I asked the hosting provider to run this script on the folder, here is the response:
“The problem is that these commands, since there is no www-data folder, will have no affect on the installation and probably produce adverse affects”

Any suggestions at this point?

I have set the permissions using filezilla, but I am getting the same error.

Also, I tried 7.02 and I am having the same problems.

I have it working partially. I still get the error message I originally stated after I hit save, but the meeting gets created. If I go to quick edit from the calender on the home page and enter information there, I get an error message that says “error while saving” but it does save the changes. Any thoughts on this?

www-data is the default user Apache uses and is also a linux group, it is not a folder. They may have misunderstood the request, you are not requesting permission update on www-data, you are changing ownership (chown command) to the entire webroot directory recusively to that user. Then you are changing permissions (chmod command) on the files will mentioned.


Thank you. I will reach out to them again. Do you really think it is an ownership issue? It doesn’t seem to be a permission issue.

I agree with Will that it looks like a permissions issue.

Need to be sure that they execute the chmod command to recursively set all the files within the diretory as well (chmod -R 7XX /dir, etc.). Setting ownership (chown -R www-data:www-data /dir) is important to allow Apache to modify SuiteCRM files.


Well, I got the hosting provider to do the above commands and I am still having the same issue. Any suggestions now?

You will need to dig into your web server php error logs and provide the exact error seen now that permissions are set appropriately. I show the previous line error in the vCal.php being related to start times based on UTC. Is this the same issue you are seeing now in the logs?

I am working on getting the logs. I have to submit a request for them. In the meantime, I have looked at the sugar logs. Right after I run the schedule meeting and get the error, I looked at the log. Here is what popped up:

Fri Feb 21 10:16:21 2014 [4327][1][ERROR] fromUser: Conversion of from user format m/d/Y h:ia failed
Fri Feb 21 10:16:53 2014 [7531][1][ERROR] Unable to load custom logic file: include/SugarSearchEngine/SugarSearchEngineQueueManager.php
Fri Feb 21 10:16:53 2014 [7531][1][ERROR] fromUser: Conversion of from user format m/d/Y h:ia failed

NOTE: The task that is creating the error is the only thing I ran

I am not sure if it has anything to do with this problem or not, but the second line states it cannot load a custom logic file. I searched for that file and did not find it anywhere. Could this be the root cause of the problem?

Looks like you are calling modified code in the custom directory that isn’t there. Did you upgrade or modify the system in anyway with studio? This issue is mentioned on the SugarCRM forums. May want to investigate the following post.

1 Like

I installed Suite CRM and then pointed it to a database that I was using for sugar. In that original Sugar I used Studio to change some minor things, such as reorganize, add and remove fields from the layout.

I did a fresh install of SuiteCRM 7.02 and it works fine. You are correct about your assumption. I thank you for that. Do you know of a way to fix this so that I can use Suite with my current sugar database?

I followed the recommendations on the site you posted. Unfortunately it did not work. I searched the bug in sugar and it seems that it is still apparent even though it says closed. The permissions on the file that I modified are 664. Is this correct? Could it possibly not be rebuilding due to a permission issue?

My assumption would be that a combination of SQL and PHP will be needed. Could be messy. You may want to see if you can contract one of the SuiteCRM guys for a month to get it sorted.

If you have access to the old SugarCRM server you may need to pull all the additions you made to it in studio and do a DB dump. Studio>Export Customizations. Install SugarCRM 6.5.X clean with a new DB, import your old DB, then install the customization export. Repair Rebuild, set permissions, then run a SuiteCRM upgrade.

1 Like