Problem to install SuiteCRM on UBUNTU 19.10

Hello guys, I’m trying to install SuiteCRM 7.11.13 on UBUNTU 19.10, but I have some technical troubles to install the right version of PHP.

I have already PHP 7.4.5 installed on UBUNTU, but I’ve heard it wasn’t compatible with the last version of SuiteCRM, and I’m trying to find how to install only PHP 7.3 version. I have already Nginx and SuiteCRM installed on.

Can someone help me to handle the problem please ?!

Hi and welcome to the forums!

You’re right, PHP 7.4 isn’t officially supported. Try installing package php7.3 instead of php7.4. By a quick glance it should be available in Ubuntu 19.10.

If you don’t need php7.4 for some app, I’d recommend removing that and using only php7.3. If you need php7.4 specifically for something then you need to research running multiple versions of php simultaneously.

Note that you’ll also need to install 7.3-specific versions of most packages, e.g. php7.3-fpm.


I’m actually trying to desinstall the 7.4 version of PHP with my terminal. I already tried to do the commands “sudo a2dismod php7.4”, and then “sudo a2enmod php7.3”, but when I enter the command “php -v”, it display “PHP 7.4.5” although it was supposed to have been disabled.

Have you an idea about the right procedure to use to desinstall php7.4 and only use php 7.3 ?

a2enmod and a2dismod are apache-specific commands and only affect the environment within Apache. They only enable or disable modules on Apache. If you’re using only nginx they’ll be of no use. Unfortunately I’ve got no experience running php on nginx (I’ve only run nginx as a proxy in the past) so I can’t help you with that. You’ll need to figure out enabling specific php version on nginx on your own.

When you run /usr/bin/php on CLI, you’re actually running a symlink to whichever php version is linked to it. Apparently in your case it’s linked to php7.4, and so when running php -v on CLI you’re actually asking php7.4 for its version; hence the output is “wrong”. You can check if php7.3 is installed by running php7.3 -v on CLI. You should be able to force nginx to use specific php version; on apache you’d simply use a2enmod.

To use php 7.3 you can either

  1. remove php7.4 completely by apt remove php7.4 or apt purge php7.4. You might need to run dpkg-reconfigure php7.3 afterwards to fix the links; or
  2. leave 7.4 installed and force nginx to use php7.3.

You also need to make sure that you’lle be running Suite’s cron with the correct php version. If you chose option 1, you don’t need to make any changes, but in case of option 2 you’ll need to tweak the crontabbed command to run php7.3 instead of just php.

I personally use only Debian so there might be some differences (like using sudo instead of root account), but the basics should be the same.