Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

Problem installing SuiteCRM8

Hi there,

I have a problem installing SuiteCRM8 on Ubuntu.

I made it to the “Welcome to SuiteCRM - Install” page, where you enter db parameters. After pressing “Proceed”, i got the warning that upload_max_filesize was to small. Fixed that. So the first check worked. But, when i now press “Proceed” nothing happens.

Nothing in php Apache’s error.log, where PHP erros are written (yes, they are) nor in the suitecrm.log

With the browser’s debug window the I see an async

POST <nothing interesting here>/api/graphql

with the response

{
  "data": {
    "createProcess": {
      "process": {
        "_id": "suitecrm-app-install",
        "status": "error",
        "async": false,
        "type": "suitecrm-app-install",
        "messages": [],
        "data": {
          "statusCode": 1,
          "errors": []
        },
        "__typename": "Process"
      },
      "clientMutationId": null,
      "__typename": "createProcessPayload"
    }
  }
}

How do I tackle this?

Best
Lars

Hi @larsschaps,

Thank you for trying out SuiteCRM 8.

Two things you could check:

  • logs on logs/prod/prod.log

If nothing on the above:

  • On the file .env change the APP_ENV=prod to APP_ENV=qa
  • try to install
  • check the /api/graphql call again, it should have more info on the error

Hope this helps

Hi @clemente.raposo ,

thanks for the advice. Thanks to you, I found the logs/install.log.

Obviously, the OS process didn’t have write access to the root directory.

Lars

Hi @larsschaps,

Glad to hear you able to solve it.

If you have any feedback, please consider having a look at the following topic: