Print pdf - acrobat reader error message " could not open because it is either not a supported file type..."


I have selected the list of leads I want to print to pdf and have selected the template but after a while acrobat reader opens and gives the above message.

Please help

Please include the FULL text of the error.

Is this Windows or Linux?

Can you get the file to save on disk first, instead of opening it directly in Adobe Reader? If so, is it a valid file, with a valid extension, with more than 0 bytes, with proper permissions to read it?

Thanks for your response.

i am using windows 10.

I have saved the screen shot of the error on we share link below

The process I am following is

  1. I select leads list
  2. I select the leads I want to print
  3. I select print as pdf under bulk action
  4. I select the template (There is no print to disk option)
  5. Acrobat reader opens and I get the error message.



SuiteCRM is sending a PDF file to your browser. What happens when it receives the file, is a browser option.

So if you search online for how to configure your browser to let you save PDF files, instead of opening them, you will certainly find instructions.

It helps if we can have a look at the file first, and try opening it in a different PDF Reader, for example.

Thanks for your assistance.

I managed to download the file without opening it by using explorer instead of chrome.

But the file wont still open when I try using adobe reader and even illustrator! Still get the same error

I uploaded the file on we transfer here

What could be the problem. I have tried the process on a different computer but same result

I opened your file in Notepad++ and it is corrupt because it has a bunch of PHP errors in the beginning of the PDF. Stuff like this:

<b>Warning</b>:  Illegal string offset 'ID' in <b>/home/readafr/public_html/suitecrm/modules/AOS_PDF_Templates/PDF_Lib/classes/cssmgr.php</b> on line <b>1353</b><br />
<br />
<b>Warning</b>:  A non-numeric value encountered in <b>/home/readafr/public_html/suitecrm/modules/AOS_PDF_Templates/PDF_Lib/mpdf.php</b> on line <b>32036</b><br />
<br />
<b>Warning</b>:  Cannot assign an empty string to a string offset in <b>/home/readafr/public_html/suitecrm/modules/AOS_PDF_Templates/PDF_Lib/classes/cssmgr.php</b> on line <b>1070</b><br />
<br />

When you upgraded, you probably saw an instruction telling you to run “composer update” on your SuiteCRM root directory. There is a new version of the PDF engine in these new SuiteCRM’s, that’s why you need to update.

If you get an error that “composer” does not exist, look for instructions online to install it on your computer.

Thanks for your reponse.

I am currently on suitecrm version 7:10:10

Please, Does this mean I upgrade to version 7:11 or how do I update the composer on its own?


I went ahead and upgraded to version 7.11.1

Still no lack I have the same error.

It didnt show any message regarding composer when it was uploading

What next please?

“Composer” is a separate program, it is the package manager that SuiteCRM uses to manage its dependencies (3rd party software bundled with SuiteCRM).

To run composer you simply go in to a shell (command prompt) on the root of your SuiteCRM installation and type “composer update”.

If you get an error saying there is no program called composer in your system, then Google for something like this:

“install composer on Windows 10”
“install composer on MacOS 10”
“install composer on Ubuntu 16.04”

then follow those instructions, then retry the “composer update”.

Thanks for this.

Tried but got this error.

see screen shot please

Please, what can I do next?

I’m sorry, I never saw that error before. You would probably be better off asking in some Composer forum or Stack Overflow.

But start by going into your php.ini and trying to find something similar to that parameter mentioned in the error message…

Thanks for all the help. I cant seem to find any php.ini file except travis.php.ini when I search for it in all folders when logged into the cpanel (with show hidden files checked)

is it the same thing or do i have to create a php.ini file?

Is this your server or is it a shared hosting?

You can check your actual php.ini path in Admin / Daignostic / phpinfo