PHP Version Compatibility?

Hi All,

Which is the latest official PHP version that SCRM 7.1.1 is compatible with and have successfully been tested on? 5.3.x?

Compatibility for PHP 5.4 and 5.5 is only in the roadmap for SCRM 7.2.0… so I guess that it is not recommended at all to try and use either of those 2 later releases with 7.1.1? If you do make use of them, which features may not work correctly?

Werner

Hi there,

In 5.4 you will get many strict standards errors and bugs. In 5.5, there are some more immediate issues such as the homepage not showing correctly and general bugs.

We would advise running on PHP 5.3 until newer versions of SuiteCRM are releases that are compatible with newer versions of PHP.

Thanks,

Will.

If you know how and have the opportunity, you might try with 5.4 because Suite will run faster. We’re running on PHP 5.4.22 and had no issues with Suite. Of course, we didn’t run the installer so I don’t know if that might cause an issue when the next update comes down the line.

The official word of PHP.net is that … well there hasn’t been any EOL word from PHP in a long time beyond “real soon now.” It was announced a year ago and then pushed back such that 5.3, 5.4, and 5.5 are out there and just confuses the hell out of developers as to what to do.

You KNOW the EOL (end of life) for 5.3 is coming so it would be prudent to start running Suite on 5.4 if it works. And it would be prudent of the Suite development team to make sure it works!! :slight_smile:

Tried it with 5.5 actually as this is the standard install that comes with Ubuntu Server 14.04 now. The majority of features/functions do seem to work okay but you have to turn error_reporting in PHP down to E_WARNING instead of E_ALL otherwise it becomes unusable with STRICT warnings and errors.

There are some features though that don’t work correctly (either at all or passes unexpected errors), so I decided to do a full downgraded installation of both Apache and PHP to 2.2 and 5.3 respectively, on 14.04. Have just finished with the whole process and it completed very smoothly except for one error right at the end of the installation process.

The installation summary shows this error when its done:
Warning: Invalid argument supplied for foreach() in /Data/Local/Websites/crm.softselect.biz/site/modules/AOR_Reports/AOR_Report.php on line 85.

Any ideas what could be the cause of it?

Werner

This has been addressed in Suite earlier:

http://suitecrm.com/index.php?option=com_kunena&view=topic&Itemid=1136&catid=7&id=32

Personally I’d turn off the warnings. The ‘problem’ is that PHP 5.4 and 5.4 are more strict when it comes to operating on arrays… foreach() expects the argument to be either an array or an object… if they are not arrays or objects it throws the warning, but still works.

If you know how to get into the code you can see this fix by casting the variable as an array:

http://www.euperia.com/development/php/fix-php-warning-invalid-argument-supplied-foreach/1230

The problem with fixing the code is that unless the developers also do this, the next update will perhaps overlay that module.

It’s just a warning… not a big deal if you turn off the warnings! I would not sacrifice the speed and efficiency of 5.4 or 5.5 because of a warning on the install but it is up to you.

Sorry to did up this old thread but it seemed directly relevant to my question - Isn’t it about time SuiteCRM moved to at least version php 5.4. AFAIK all the releases officially supported by SuiteCRM are no longer supported by the php team.

https://suitecrm.com/wiki/index.php/Installation#PHP_version

1 Like

Compatibility-matrix