php.ini - changing max file upload size

I am trying to upgrade my suitecrm and I ran into the config problem of my max file upload size is too small to be able to upload it.

I used the suitecrm feature of
Admin: Diagnostics
to see the phpinfo

I did find the php.ini file this way and found that the value was too low.

I changed it.

I rebooted apache

I then proceeded to upload the upgrade file again.

It failed because the max upload file was still too small.

I then realized that the php.ini file that I changed had a 2 MB limit.

The error that comes up says it has a 8MB limt.

It seems that the php.ini file I change was not the right one.

Here is the text I changed:

; Maximum allowed size for uploaded files.
upload_max_filesize = 128M

Let me know what I might have missed or done incorrectly.



Hi, please try to also change the post_max_size

post_max_size = 8M

Afterwards, depending on your setup, restart your webserver (apache/nginx) or your php_fpm.

This solved it.

Thansk fo rthe help!!

Changes to php.ini have zero affect. I changed the like 4-5 suitecrm recommended values.


I change and then restart apache.
systemctl stop apache2
systemctl start apache2

Then do another suitecrm diagnostics - no change to in memory values. Same error trying to upgrade about exceeding 52M

This is a recent Univention vmware install which works - just can’t upgrade now.

I don’t have php-fpm nor ngnix.

Seems like the normal php.ini has been circumvented somehow by these Univention people.

post_max_size = 60M
upload_max_filesize = 100M
memory_limit = 300M
file_uploads = On
max_execution_time = 180

1 Like

Yes, I know, I know - selecting the parameter values is not the issue. Getting the changes to actually take effect (even after restarting Apache), is.

Hi jakorsme,

  • please check if the lines you want to change start with a semicolon ( ; )
    remove this semicolon when you are changing these lines.
  • Create a file phpinfo.php in your suitecrm root with contents

Go to http://your.suite.instance/phpinfo.php and check in “Loaded Configuration File” if php is actually using the php.ini you are changing.