PHP 5.6 ???

Since I upgraded my server to PHP 5.6 (default php in debian 8), there are a lot of errors an problems loading different pages or actions.

The Suite is exactly the same I used in 5.4, same database.

Before posting here I’ve tried many things (Quick repair, check permissions, reconstruct database…) and changing all the options in php.ini I’ve read in other posts:

/etc/php5/apache2/php.ini --> display_errors = Off
/etc/php5/apache2/php.ini --> error_reporting = E_ALL & ~E_DEPRECATED & ~E_STRICT

But the errors persist:

PHP Notice: Array to string conversion in /var/www/crm/include/formbase.php on line 203, referer:----

PHP Notice: Undefined offset: 1 in /var/www/crm/download.php on line 110,


PHP Notice: Undefined index: screen_width in /var/www/crm/modules/Calendar/index.php on line 65

I can’t load, for example, New meeting from Calendar. Or some alerts from ajax (the Loading box) are shown as Undefined…

In all cases is a new install server, without any other website, but if I just rsync all suite from the new server to a old one (lets say debian 7) everything works.

Any advice???

What can I look?? PHP???

Thanks a lot!.

PD: SuiteCRM 7.2.1

It looks like your php.ini isn’t being applied (or is being overriden) can you check phpinfo() to see if display_errors is indeed off?


It’s enabled…

Weird, It may be that there is some code which is enabling display errors. There shouldn’t be any code in SuiteCRM which is enabling this. You may want to do a search of the code to see if ini_set is being called anywhere.

Why shoud show errors in the code if the same code in one server (php 5.5 or 5.4) does not show errors and in the php5.6 it does?

Anyway, in the server I’ve searched for display_errors in code:

# grep display_errors * -R
cache/diagnostic/92a2d618-60e8-e0e1-264d-556c0766ec58/diagnostic20150601-092110/phpinfo.html:<tr><td class="e">display_errors</td><td class="v">Off</td><td class="v">Off</td></tr>
include/HTTP_WebDAV_Server/Server.php:        ini_set("display_errors", 0);
include/utils.php:	ini_set('display_errors', 'false');
modules/Home/Dashlets/ChartsDashlet/ChartsDashlet.php://		ini_set('display_errors', 'false');
modules/AOS_PDF_Templates/formLetterPdf.php://ini_set('display_errors', '1');
upload/upgrades/patch/SuiteCRM-Upgrade-7.0.x-to-7.1.6-restore/include/utils.php:	ini_set('display_errors', 'false');
upload/upgrades/patch/SuiteCRM-Upgrade-7.1.x-to-7.2.1-restore/include/utils.php:	ini_set('display_errors', 'false');
upload/upgrades/patch/SuiteCRM-Upgrade-7.1.x-to-7.2.1-restore/modules/AOS_PDF_Templates/formLetterPdf.php://ini_set('display_errors', '1');
Zend/Loader.php:     * Always set display_errors = Off on production servers!

Does anyone using suite in php 5.6? (maybe the problem is debian jessie 8?)

Thanks for the help!.

Also this one also had problems with debian 8, but it just went back to 7. For me it’s not possible to change the server OS.

By any chance is Scream installed? You can check for the scream.enabled ini setting in PHP ini or in phpinfo().


I don’t have this option (not in php.ini neither in .htaccess or any phpinfo().

I’ve also tried to set up a 777 file permissions in all suitecrm folder and subfolders (in a testing enviroment) and nothing changes.


Also, there are a lot of messages showing “undefined” in spanish language (in english it’s working fine). I’ve tried all options in repair page, but it does not work.

It looks like a lot or problems with this version of debian 8 jessie, or apache or php, does anyone has migraded to the new version of debian?