Permissions help

I need help with file permissions in suitecrm, i can change them but they change back after a certain time i found the code below in config.php - what should it be set to.

‘default_permissions’ =>
array (
‘dir_mode’ => 1528,
‘file_mode’ => 493,
‘user’ => ‘’,
‘group’ => ‘’,

what should it be set to, running 7.7.3

check this post

best regards

Thanks for the info/link mikebeck,

www-data definitely doesn’t work on my system… breaks everything.

I don’t think it is the right way to do it, but I chown everything to my account user/group and then left the permissions as default (including no text in the default user/group)… I haven’t had any issues.

Furthermore, Apache is running as nobody:nobody, but putting that in breaks everything as well.


sieberta the owner thing is really problematic because it depends if the webserver is selfhosted, shared host, if you configure it in a specific way, but let me tell you that if you install an Ubuntu Server 16.04 with LAMP the user and group will be www-data

I had worked several years without the explanation from Will above but at the moment and using another language pack I have several problems that are all logged but never taking care of because it only affects other laguages.

I wish I could work only in english but I can’t

best regards


thanks for your help, i am setting this up on a sub-domain if that affects anything and im using linux not ubuntu.

The problem i had the problem of undefined and and found this was due to the files permissions, so if i change them after a while they change back - how can i fix this

I’ve heard of many people having that problem, but I haven’t had it and I don’t have any recommendations… it seems like you’re headed down the right path, I just don’t know what to tell you those settings should be.

FYI, Ubuntu is just one flavor of Linux… it is still Linux.

Are you running this on a CPanel Host? Shared/VPS/Dedicated or your own hardware or VM?


cloud hosting


Not quite as much information as I was hoping for, can you just indicate who the host is, and whether or not you used a 3rd party to deploy on that host like Bitnami?


tso host

I asked because if it has Softalicious, you could do another install and see how it chowns the files, as this is what worked for me. Otherwise you could ask TSO…

Actually, is the problem with permissions the wrong user/group for items, or is it the actual permissions like 775, 755, etc.?