Permission - sudo chown -R www-data:www-data - user does not exist

I need some help.

SuiteCRM is installer via Softaculous on SharedHosting. I dont have SSH.

I do not have a direct line for SSH, but administrators are willing to type commands that considers necessary. I hardly convince them to do that. Here we come to the problem.

I asked them to enter: sudo chown -R www-data:www-data

Their response is: We tried. "can not change owner for dir to username that does not exist as a user. User www-data does not exist as a user '.

I dont know what to do.

[size=4]Will I have problems during work if this command does not implement???[/size]


Depending on your hosting environment you have to setup ownership to whatever user the web server is running as.
This gets complicated depending what cp if any you are using as well as which OS is used.
You then have many many combinations possible so it requires the help with someone with expertise in hosting.

The short answer is:

  1. find out from your provider under which user name is the web server running for YOUR account (in case the server runs suexec it should be your account usedid) and
  2. replace www-data whith the username provided

This should allow you to run it.

The permissions documention of suiteCRM lacks many details on this critical issue as if fails to explain these critical issue. For instance I never found out why the language file would not install. I saw they were uploaded under a different user id but they just will not install.

Make sure you can read the logs too to find clues on what is wrong, for me I had to replace the Options +FollowSymLink with +SymLinksIfOwnerMatch to allow for my environment.

Overall SuiteCRM is great BUT requires a good deal of hosting knowledge, a lot of patience and a lot of time before you can seriously deploy it.
I am struggling now to upgrade and it is so bad that installing brand new seems faster than waiting for answers that never come.
I hope some developpers will start some consulting firms to help us out.

Good luck.

1 Like

Thank you for fast answer.

I will try to make a deal with my hosting provider.
You’re right. Requires companies that can set SuiteCRM in a professional manner. In Serbia, there is only one company that deals and it is reserved only for large customers.

I will keep trying to see how to make it working. The problem is that I am not a programmer, every beginning is difficult, but I have a strong desire to implement CRM system in my new business venture.


This morning within 2 hours I fixed ALL my problems and everything works just fine now.
I changed some settings in my hosting environment under Centos 7 virtualmin

  1. First I changed the server mode from mod_php to mod_fcgi; this allows for custom php.ini per host
  2. Then a made sure and corrected all files ownership, they needed to be under the account userid NOT apache or nobody
  3. I could load and install languages as well as upgrade with no more issues.

Hope this help someone.