PDF Templates and barcodes

Hi all

I’m hitting a wall trying to troubleshoot this, so I’m kindly asking for help or even just ideas, what could be wrong.

I needed to add barcodes to certain PDF Templates and planned on using mPDF’s tag, which would fit my needs perfectly. However as I tried to add the tag in PDF Template editor, the editor (TinyMCE) would strip it out. When I skipped the editor and added the tags directly to database recods of the templates, they’d work fine, but I can’t change the templates in editor without readding the tags to database.

I ran accross this issue which matches what I’m experiencing, but that was fixed long ago. I even checked and modules/AOS_PDF_Templates/views/view.edit.php matches that of the pull request fixing the issue, so it should be ok. There is no custom version of the said file either. Any ideas what could be wrong?

I’m running running SuiteCRM 7.11.8 on LAMP stack (Debian 10 & MariaDB). The SuiteCRM installation has been around since 7.2.1, so there are probably still old settings and files lying around and causing this. I just can’t figure out where to look for them - or what to look for.

Thanks for any input!

Maybe try to compare where mPDF gets installed, and which version gets installed, in your system, versus a clean install of the same version of SuiteCRM.

This happened a while ago: https://github.com/salesagility/SuiteCRM/pull/7118

So you coudl try making sure you have composer installed, and then running this from your SuiteCRM root folder:

composer install --no-dev

Also, you might post a comment on that issue you found, https://github.com/salesagility/SuiteCRM/issues/4389 maybe someone there can help…