PDF Template content gets trimmed


I have tried multiple times to create a PDF template:

  1. by pasting the full content of pdf
  2. by pasting the HTML content directly

But, the whole content does not get saved, and 10-20 lines at the end are not saved in the pdf template.
Consequently, the PDF printed does not include the full content.

I also want to mention that the content is very big, so that might be an issue. If that is the case, how can I overcome it?

Pls help, its urgent


I had this issue a long time ago. There is a maximum limit to the size of PDF templates.

Can you tell me where this setting is? I’ll try to change it.

Or maybe, if you can tell how you solved the problem?

As I understand it there is no solution it’s a limitation of the field size in the database where the data is stored. I could be wrong however. I know I ran into this a few months ago and had to re-word my contract to make it fit.

Have a look at this pull request: https://github.com/salesagility/SuiteCRM/pull/3532