pb with csv export need your view

hello when I export opportunities the csv file can have error when the field ‘description’’ is filled
the export consider each return in the text as a new line
and it creates difficulty to transform the csv as a xl sheet

does anyone have the same pb and find any solution

Many thanks


this works fine for me. It’s not really a SuiteCRM issue, it has to do with your Excel settings and your Windows settings (is it WIndows you’re using?).

SuiteCRM produces a correct CSV with “” quote marks as delimiters, and commas as separators. According to your Windows regional settings, this will be correctly interpreted by Excel or not.

Here is the sample CSV that I used to test, exported from SuiteCRM, and which opens correctly in my Excel:

"Opportunity Name","ID","Opportunity Amount","Currency","Expected Close Date","Sales Stage","Probability (%)","Next Step","Type","Account Name","Description","Amount","Lead Source","campaign_id","Assigned to","Assigned User","Date Created","Date Modified","Created By","Modified By","Deleted","Latitude","Geocode Status","Longitude","Address"
"Kringle Bell IncK.A. <b>Tower</b> & Co 1000 un","10958bcd-5659-5c21-5695-5bb887c46b8f","$75,000.00","-99","06/11/2018","Qualification","40","","Existing Business","Kringle Bell IncK.A. Tower & Co","","$75,000.00","Existing Customer","","chris","seed_chris_id","06/10/2018 10:00","26/10/2018 20:00","1","1","0","0.00000000","Empty","0.00000000",""
"OTC Holdings - 1000 units","17003166-818d-b7aa-61b4-5bb887a35737","$75,000.00","-99","17/07/2019","Prospecting","60","","","OTC Holdings","This
","$75,000.00","Self Generated","","will","seed_will_id","06/10/2018 10:00","26/11/2018 11:10","1","1","0","0.00000000","Empty","0.00000000",""

thank you I am using windows and Microsoft excel
when I see your csv i have exactly the same type of data and as you can see
is made on 3 different lines
when i clic on convert data in excel it does create 3 lines and my file is corrupted

For me it works fine. Have you checked your Windows Regional settings? Delimiters, etc.

Also, I am not using any Excel “convert data” button. I am simply double-clicking the CSV file in File Explorer, so I am simply doing a “file-open”

and here it is my results when i open the csv file

Name,“ID”,"Montant Affaire ","Devise ","Date de cloture (prévue) ","Phase de vente ","Probabilité (%) ","Prochaine étape ",“Type “,“Nom du compte “,“Description “,“Montant “,“Origine du prospect “,“Campaign ID”,“Assigned User Name”,“Assigned User ID”,“Date de création”,“Date de modification”,“Created By ID”,“Modified By ID”,“Supprimé”,“type de produit”,“Description jl”,“Status Géocode”,“Longitude”,“date de livraison”,“Financement”,“Adresse”,“Latitude”
test description,“1bdadd8f-caaf-0f48-6056-5bfab4e09c2f”,“€35,000.00”,”-99”,“30/11/2018”,“Prospection”,“10”,“on doit se rappeler. il est pas sur”,“Récurrent”,“chmol”,“fdfdfdfd
uuuuu”,“€35,000.00”,“Partenaire”,””,“admin”,“1”,“25/11/2018 15:39”,“25/11/2018 16:12”,“1”,“1”,“0”,“Type A”,””,””,“0.00000000”,“30/11/2018”,“Cash”,””,“0.00000000”

In Windows Regional settings (believe me, it’s there), change your list separator from “;” to “,” and the CSV will open just fine.

I modified my regional parameter in windows and it works well now.
Many thanks for your help
really appreciated

in case of do you know how to suppress a field. I created a field and now when I want to suppress it i clic on suppress and nothing happen

My best

Sorry, I don’t know what you mean by “suppress a field”. Where exactly are you, and what do you click?

i mean delete a custom field created with the sudio
and finaly i found the solution by not using the french translation and now it works

many thanks