password don't get sent, can't add new user


I have recently installed SuiteCRM and run it as the admin user that you can add during the setup process. I wanted to add a new user, but for some reason they never get the email with their password - but the email settings work, as I can send emails (and test emails in the email settings) from the CRM.

When I create the user, I get this error:

System is unable to process your request. Please check:
-SMTP Server URL and Port
-SMTP Username and SMTP Password
-Recipient Email Address
-Your server status

When I try to reset the password for the same user afterwards, I get this:

System is unable to process your request. Please check: -Recipient Email Address -Your server status

Anyone got a solution?

Did you try setting ownership/permissions to your html directory? Possibly a module trying to leverage email function and can’t? Validate any logs to see what is going on?

This is a brand new install of SuiteCRM 7.0.2, nothing added to the regular installation. There was no warning on install either.
Permissions are set to 755 and owner is www-data:www-data, shouldn’t be a problem here.
The server’s email logs show nothing in particular (neither when emails do send nor when they don’t, such as when I add/reset password for a new user), so I really wouldn’t know.

Turn log level up to see any email related errorsHere. Do you see the attempt to relay being initiated on your mail server?

Now that’s weird. I tested again (for the 20th time today…) when I received the notification for your message, it didn’t work. I then went to change the log level, showed the log, and did absolutely nothing else. Then retested resetting the email of a user: it worked…

I still have no idea what went wrong before (I tested installing SuiteCRM on 2 different servers, with the same results!) or what I have fixed, but at least it works now. :slight_smile:


That’s funky. Glad you are good to go.