Page Response Very slow

Recently, I got a problem that when click module “Accounts” ,then “loading page,please wait…,” was shown for a long time(at least one minute) while other modules response in a second. And I found that the result message are different – It shown “No results found… Perhaps change your search criteria and try again?” in module"Accounts" while other modules shown “You currently have no records saved. CREATE or Import one now.”

Anybody can help find the reason? It’s such a big problem.

We’ll have to know a few things about your system in order to help you…

What are your versions of OS, database, web server, PHP, SuiteCRM? Where is it hosted?

What do you see in your logs (suitecrm.log, php_errors.log) at the time of the failed queries?

How many Accounts do you have, and how long have you been running this system? We need to get an impression of how big it is.

Thanks for your quick response.
Please refer to my CRM information below:
Linux CentOS 7.2
apach 2.4.2
mysql 14.14
php 7.0.9
suitecrm 7.8.3

At the time of slow queries, there’s only one Account in my SuiteCRM and there’s no error log. We had been running this system since 8th May,2017. Yes, we’re just at the beginning!
I found a strange phenomenon, the very slow queries only happened in some users ,including user “admin”. It means that A and B , two users with same role, when A click Account , the query is very very slow but when B click Account , the query is normal with a fast response.
Waiting for your response! Thanks very much.

Start by trying a Quick Repair and Rebuild.

If the error happens with just a few records, and you can safely delete them and re-create them, try that also - it might solve your problem.

If you really need to diagnose the problem, however, you will have to get to your logs.

Yes, I have tried a Quick Repair and Rebuild ,after that ,I have delete the Account and re-create it, but the problem is still there.

The queries for Account are very slow, but sometimes, the queries have results after about one minute , sometimes there’s an error after one-minute’s query and the error in log :Error retrieving SecurityGroup list: Query Failed: SELECT securitygroups.* , jt0.user_name assigned_user_name , jt0.created_by assigned_user_name_owner , ‘Users’ assigned_user_name_mod FROM securitygroups LEFT JOIN users jt0 ON AND jt0.deleted=0
AND jt0.deleted=0 where securitygroups.deleted=0 ORDER BY MySQL error 1054: Unknown column ‘saved_search.assigned_user_id’ in ‘on clause’ .

But in the meanwhile , another user login the system and have a same query for Account, there’s no error and the query is very fast.


You may try, delete saved search It seems issue with saved search. Or you can try with clear search in listview.

Thanks for your help. But how can I delete saved search, Sorry, I’m new in SuiteCRM, I even don’t know what’s “saved search”, could you please tell me more in details? Thanks very much!

Goto->Listview, click on filter icon.
You will see List of saved search you saved any. either you can update or delete. If you don’t have any saved.
Try clear button and search with blank, that will clear if any.

There’s no saved search in the listview and I have tried clear , then search . But nothing have been change, there’s still a very slow query for user A but very fast query for user B.
Any other ideas? Thanks!

I find it strange that your database complains about a missing column, not about a missing row of data. That indicates the database structure is out of sync with the code. It could be a bug.

But just to make sure, do a Quick Repair and Rebuild again, and when it’s finished, scroll down to the bottom of the screen - sometimes there’s a message there about updating the database structure to fit the vardefs. If it tells you that, just press the button and see if it fixes your issue or changes your error message.

… and if you know how to go into the database with phpMyAdmin or mysql command-line, check if you have a table called “saved_search” with a field called “assigned_user_id”!

I have had a Quick Repair and Rebuild again and on the bottom of the screen , there’s a message tell me :Database tables are synced with vardefs.
In the meanwhile , I have checked the database, there’s a table call “saved_search” with a field called “assigned_user_id”, it seemed there’s no problem according to the log.
It’s strange that there’s no query problem for other users except administrator and one normal user.

I’m afraid I’m running out of ideas…

Maybe try MySQL Repairs, or upgrade MySQL to see if there’s some bug that gets fixed…

Check DB like pgr said, also what are the server specs? ram and cpu. Have you tried a fresh install for testing purposes on the same environment?

My CRM is running at AliCloud .
When I found this problem first time, I re-installed a new CRM . But the same problem came after some configuration had done.
I think it should be something wrong with my server, because I have restored the CRM to another server today, the problem disappeared!
I’m going to have a check on my server. Thanks for your help.

Finally, I find out the reason. I found that when I click ‘Account’ which response very slow I mentioned in this topic, I didn’t know why the default filter is “Advanced Filter” while other modules is “Quick Filter” . When I changed the filter to “Quick Filter”, the page response very fast.