Optimise AOD Index not running?

Should I be concerned that Optimise AOD Index shows last successful run as never, but job status is done?

I finally got cron working (1and1 shared server so it was quirky) but this is the only thing that stood out so far (because I was trying to get AOD search working and I assumed this was why it wasn’t searching correctly).

Weird, I disabled and then re-enabled AOD and now it shows as last ran successfully. However if I change the schedule to 1 minute, it doesn’t update the last ran time, only marks as done below. Is that to be expected?

I’m assuming it isn’t working correct as whatever I search results in a blank page. Regular sugar search works fine.

Look for data in ~/modules/AOD_Index/Index/Index. If these files are being modified, then the index itself is being created and such.

It also might just be taking a long time to perform the search. Or it might have to do with a bug, which was fixed in 7.2.1.

The only file there is read.lock.file, which is blank.

Any ideas?

I just realized it will only run if AOD is not enabled… Hmmmm

Did you ever resolve this problem in the end?

I have a problem where the job seems to run but no indexing seems to be done. There are no search results when searching.

I had to remove the modules/AOD_Index/Index/Index folder and rerun search or the job and it recreates itself.

How do we get it to reindex again since the job does not seem to work in scheduler?


Did you get a solution ?

Thanks a lot