Opportunity - Contact Relationship - shows all e-Mails of contact

Hey everbody,

I’m not sure if this behaviour is an error or it works as designed:

If I’m adding a contact to an opportunity all emails of the contact are shown under the course. This seems wrong to me because the mails aren’t related to the opportunity.

Is it possible to disable this behaviour?

I’m using

Version 7.11.20
Sugar Version 6.5.25 (Build 344)



Interesting. I’m not able to replicate that on the demo site.

Can you explain your steps?

My own steps were:

  1. Create a new contact with an email address
  2. Archive an email to contact (thus it appears in Contact’s History subpanel)
  3. Relate Contact to an existing opportunity
  4. View on Opportunity record the History subpanel is empty (thus not showing the Contact’s archived email).

Hey samus-aran,

thanks for your reply. I just solved the problem. I t is a seeting in the admin menu. I’m not sure how it is called in english but I try.

You can disable the behaviour in admin menu -> History Subpanel -> uncheck opportunities.

After I did this the E-Mails of the contact won’t be shown anymore. But if I connect a mail directly to the opportunity the E-Mail is shown.


1 Like

Awesome! I’ll mark your own answer as the solution :wink: