OpenLDAP integration


I am trying to get SuiteCRM to integrate with OpenLDAP. I have even put OpenLDAP in full debug mode. I cannot figure out what information and the format it requires. (This is the first of about 10 apps that I have LDAP integrated that has caused me pain like this. Everything else has been pretty straightforward)

I can perform an ldapsearch on the tree from the machine in question and get a full dump of the database using ‘anonymous’ bind.

I go into: Admin->Password Management

I see this:

Password Management

LDAP Support

Enable LDAP AuthenticationInformation: check in the radio box to enable

Server: IP Address of my server

Port Number:389

User DN: ou=people,dc=example,dc=com

User Filter:

Bind Attribute: dn (where DN is: cn=Joe Smith (in the login screen on SuiteCRM))

Login Attribute: (I’ve also tried uid which is a record in the DN)

Group Membership:


Auto Create Users:

Encryption Key:

SAML Authentication
Enable SAML Authentication:

Now, I’ve tried many different things on the login page:

cn=Joe Smith
jsmith (the uid)
etc, etc.

I get either incorrect credentials or invalid DN.

Does anyone have this working?

(Yes, I searched the forums but there’s 4 entries with no responses.

Thank you,


Hello pathiaki,

Your post has been here for 1 year and 4 months now without any answer . I’m wondering if you have solved this issue and provide me ( and others that have this issue) with a solution.



You should be able to use openLDAP with the settings below:

Server: ldap://
Port Number: 389
User DN: ou=Users,dc=test,dc=server,dc=com
User Filter: {BLANK}
Bind Attribute: dn
Login Attribute: cn

1 Like

I just installed SuiteCRM and had the same issue. My AD is a Windows 2008 R2 server.
I got it working with the following:


Port Number:

User DN:

User Filter:

Bind Attribute:

Login Attribute:

Authentication box:

User Name:


I hope this helps.



Thank you guys for the help. it worked for me as mentioned by Camo!


my configuration is a bit different, and it’s working.
server : 192.168.X.X
Port number : 389
User DN : ou=companyou,dc=ourcompany,dc=com
filter : blank
Bind Attribute: dn
Login attribute : uid
authentication : checked
create users : checked
username : cn=AdminUserName,dc=ourcompany,dc=com

and we enable Group Membership, if we don’t want all users to be synced to suitecrm

hello everyone

I’m trying to config OpenLDAP with my suitecrm 7.11.18
Finally, I got “No such object” error when trying login with existing LDAP user

my config
Server: ldap://
Port Number: 389
User DN: ou=users,dc=test,dc=server,dc=com
User Filter: {BLANK}
Bind Attribute: dn
Login Attribute: uid

Also, try any other combinations…
Can anyone confirm working LDAP on the lates Suitecrm?

my openLDAP structure

Got it working with openldap and group support.
I have plain directory, users and groups are placed in ldap root (dc=somename,dc=smn)
My setup is on a screenshot.