One-to-Many User field won't save

I think I have found a bug with the User module and I’d like to know what you think. Here are the steps to reproduce:

  1. Create a One-to-Many relationship on the User module, to any other module (So it’s 1 user to many of the other)
  2. Go to the other module and add the User field to the Edit layout (and to the display, or sync the display and the edit views)
  3. Do a repair/rebuild
  4. Try to save a record. The user field will not save.

I tried the above procedure with other field types, and they work properly. After much debugging, I was able to determine that Studio was not creating the link field on the User side. After manually adding it, it works.

Still no idea why it works for other modules. Does any know if this a known issue?

I’m using Version 7.11.3
Sugar Version 6.5.25 (Build 344)

@tmath your version is old. Have you tried on the latest version? We are at version 7.11.10 when writing this post.

Try to duplicate it on this demo and let us know your findings:



@AlxGr I encountered a problem with the demo site. In Studio, when I try to go into any of the module sub-sections, I get a 500 response from the server.

Yeah I know my version is a bit older. I’m just running it on VMWare for now. I might try updating it, but I was afraid it might break something.

Any idea what’s going on with the demo?

Unfortunately I don’t have control over the demo.