Old problem still happening--Editing an Account Email loses the previous email info

When we edit an account to edit ANY fields the previously entered email address is blank. When the account is created we can enter an email address. Opening the Account the email address is retrieved from the DB. I can literally go into the DB and find the account info and the email BEFORE editing the account. After for instance changing the address the same DB table entry is blank. I think there is a query to the DB in the initial edit retrieval that misses getting the email and populating the field in the edit page. Does anyone know how I can find where that query is? This is driving our sales department nuts. So much so that they want to find a different system.


  1. Have you tried ALL Admin / Repairs that look even remotely relevant?

  2. Have you tried this on the live demo to see if it’s a bug for everyone, or just in your system?

user: will pass: will

  1. And do you have customizations, namely logic_hooks or workflows?

Running all the rebuild / Repair scripts now.

Doesn’t appear to be a problem in th elive demo.

No Customizations Only PDF templates.

So, did the repairs solve it?

Another thing, what is your version SuiteCRM? And PHP? Are you on Linux or Windows?

Nope still the same :frowning:

Here’s the info you asked for:

SuiteCRM Version 7.8.5

PHP Version 5.6.30

Centos Version 6.6

This can be tricky to track down. Ideally, you would use a debugger to step through the code and see exactly where it’s breaking.

If you can’t do that, you can try checking your logs (both of them) to see if there are any suspicious messages there (ERROR or FATAL), or even WARNINGS if they occur at the time of editing the record.

If that doesn’t turn up anything, it may help to increase your log level (Admin / System Settings).

Finally, you can check your Browser’s inspector console for Javascript errors.

In checking the log I get this
[codeTue Nov 28 10:51:01 2017 [4199][-none-][FATAL] cron.php: running as root is not allowed in allowed_cron_users in config.php. Exiting.
Tue Nov 28 10:51:01 2017 [4199][-none-][FATAL] cron.php: root’s crontab should not be used for cron.php. Use your web server user’s crontab instead.][/code]

I checked config.php and it has

It looks like to me that asterisk is the user for cron. That is the correct user for the httpd I do not think the cron jobs are running. I used PhpMyAdmin to check the DB size and it is at 16mb

The system we are using is a Centos 6.5 system with 4g memory with a Atom processor. The base install was for a Freepbx Asterisk phone system. I stopped Asterisk and installed SuiteCRM. I am now contemplating a Clean install of Linux and moving to it. Is there a “distro” of SuiteCRM that is an all in one image?

The problem you’re getting is simply resolvable by removing the cron.php entry from the root’s crontab, and adding it to the “asterisk” user’s crontab.

But if you’re going to start a new installation, there is a very straight-forward installation procedure here: