Notify on Assignment

Version 7.11.8
Sugar Version 6.5.25 (Build 344)

I try, as admin, to uncheck Notify on Assignment. After saving the user i look and the Notify on Assignment box is checked. Please advise. Any ideas on why this is?

Thanks

Hi , Welcome .

Did you try to change the browser and make repair ?

If you get an error msgs . Please share to give a try ?

Yes, I did try this and it still didn’t make the change. First browser i used was firefox, and the other i use was google chrome.

I believe this is a problem in your version, that is already fixed in the latest. The problem was with saving anything in the user profile.

Wow. so i have to upgrade then…That sounds rough

Ideally, “upgrading” shouldn’t sound rough at all. That would mean that you have nice processes in place to test upgrades and apply them, and that you would always be up-to-date with security fixes and new features.

But I know, sometimes “ideally” is far away, for one reason or another. You can also try finding the specific fix on GitHub, and manually patching just this issue.

No i have a mirrored server that i test on before i run anything, which would include upgrades. So… It should be ok.

1 Like

Hi
I am on 7.11.15 and this is still an issue. I looked at the GITHUB link and it references inserting a code snippet into User.php, I can’t find that file in my instance. I ended up manually setting receive_notifications to 0 in the user table. I need a permanent fix please.

Hi, @msi_admin
If you can do next:

  1. Edit file modules/Users/User.php
  2. Insert code to the function ‘save’.
  • before:
...

        parent::save($check_notify);

...
  • after:
/* start insert code */
            if (isset($_POST['receive_notifications'])) {
                $this->receive_notifications = 1;
            } else {
                $this->receive_notifications = 0;
            }
/* end insert code */
        parent::save($check_notify);

That was PERFECT! Not sure why my search didn’t find that user.php file. Thank you!