Notification not showing anything or working

I have set the contract starting and ending date and also set the renewal reminder date but when the reminder time is reached I don’t get any notifications on the notification menu in the top right corner of the dashboard.

I have attached the renewal date and time set for the contract image bellow.

What are the possible settings I might have gone missing

Do I have to setup some cronjob for it to work or what is it exactly. Please let me know the procedure Thanks

You have to set up a cron job once in Linux, then SuiteCRM manages several tasks by itself. You can see these in Admin / Schedulers.

You need this to be set up in order to have Workflows, Notifications, Email, etc.

Yes I guess my setup is done already from the admin/scheduler

Did this as per the guides given there

[i]To Setup Crontab
In order to run SuiteCRM Schedulers, edit your web server user’s crontab file with this command:
sudo crontab -e -u crmecsmedia
… and add the following line to the crontab file:

          • cd /home/crmecsmedia/public_html; php -f cron.php > /dev/null 2>&1[/i] 
            

After doing this I am sending the emails but not working. Do i also need some repair and build or what

You have to check if that worked and your jobs are actually running.

In Admin / Schedulers, check:

  • if the times look correct (timezone setting)

  • in the detail of a few jobs, see the “Last run time” and whether it was successful or had erorrs

Any idea how to confirm my schedulers are working. I have repair the scheduler too. Cant figure out the right way to check if they are running or no

I can see different types of scheduler that already exist there . Which one is for the contract renewal reminder. cant see anything such that looks like associated to it. If not How can I add a new scheduler or is it not possible

If ONE Scheduler job successfully ran recently, whichever it is, then your Schedulers are running.

That’s the first thing we’re trying to determine, before looking for any other functionality.

My notification is not working at all . Though I have done the cronjob setting and the repaired the scheduler

@taragurung I would appreciate it if you would pay more attention to what I write, and answer my questions or instructions.

I am working in many threads simultaneously, it’s complicated, I get a lot of email notifications when people answer here. I don’t have time or patience to come here and tell you a THIRD time that you should be checking whether your cron jobs are running at all, any one of them, by looking at the “last run time” and checking timezone settings.

I have the same problem - none of my scheduled jobs are running, even after creating the relevant cron job as instructed. All of my jobs show status as “queued”.

I have tried used the Rebuild and Repair function on my Schedulers, but this has had no effect. Do you have anything else I can check @taragurung?

Actually, I’ve just checked the sugar crm.log file and found:

Fri Aug  4 09:00:01 2017 [28790][-none-][FATAL] cron.php: running as www-data is not allowed in allowed_cron_users in config.php. Exiting.

I then checked the config.php file and found:

 'allowed_cron_users' =>  
    array (
      0 => 'www-data',
    ),

I have no idea what’s going on…

I am working to solve the notification problem too, will let you know once it is done .

Thanks

OK, I’ve checked the Apache log, and it looks like this:

[Fri Aug 04 23:06:50.288452 2017] [:error] [pid 31429] [client 192.168.1.1:62369] PHP  12. call_user_func_array:{/var/www/ccc/include/SearchForm/SearchForm2.php:626}() /var/www/ccc/include/SearchForm/SearchForm2.php:626, referer: http://webaddress/index.php?module=Schedulers&offset=10&stamp=1501884392026782800&return_module=Schedulers&action=DetailView&record=b254ebc3-233f-a79c-374b-5984ef65425c
[Fri Aug 04 23:06:50.288455 2017] [:error] [pid 31429] [client 192.168.1.1:62369] PHP  13. Scheduler::getJobsList() /var/www/ccc/include/SearchForm/SearchForm2.php:626, referer: http://webaddress/index.php?module=Schedulers&offset=10&stamp=1501884392026782800&return_module=Schedulers&action=DetailView&record=b254ebc3-233f-a79c-374b-5984ef65425c

And this is the tail output from the syslog:

Aug  4 23:14:01 servername CRON[5395]: (www-data) CMD (cd /var/www/ccc; php -f cron.php > /dev/null 2>&1  )
Aug  4 23:15:01 servername CRON[5411]: (www-data) CMD (cd /var/www/ccc; php -f cron.php > /dev/null 2>&1  )
Aug  4 23:16:01 servername CRON[5420]: (www-data) CMD (cd /var/www/ccc; php -f cron.php > /dev/null 2>&1  )
Aug  4 23:17:01 servername CRON[5429]: (www-data) CMD (cd /var/www/ccc; php -f cron.php > /dev/null 2>&1  )
Aug  4 23:17:01 servername CRON[5430]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)

To my untrained eye, it would seem that cron jobs are running.

BUMP

@blloyd can you please double-check what you say in your post #51732?

Do you still have that exact message in your logs, and do you really have that setting in your config.php? The two things contradict each other, that’s why I’m asking…

Also, the Apache log you posted in post #51776 is just a fragment: you’re not including the error message, you’re just including lines 12 and 13 of the stack trace. Apache log messages are structured like this:

Error message

  1. call stack #1
  2. call stack #2
  3. call stack #3
    etc

OK, something I have done has caused logging to stop working - my sugarcrm.log if completely empty, and nothing new is being added to it. Any idea where I need to start looking to correct that particular problem?

Thanks.

You should be looking for suitecrm.log, not sugarcrm.log.

There are settings for it in Admin / System Settings.

OK, the logging level was set to high. I’ve rebuilt the scheduler and carried out a repair and rebuild - here is the log file output:

Tue Aug 22 12:20:02 2017 [24368][1][ERROR] Unable to load custom logic file: include/SugarSearchEngine/SugarSearchEngineQueueManager.php
Tue Aug 22 12:20:03 2017 [24368][1][ERROR] Unable to load custom logic file: include/SugarSearchEngine/SugarSearchEngineQueueManager.php
Tue Aug 22 12:20:04 2017 [24368][1][ERROR] Unable to load custom logic file: include/SugarSearchEngine/SugarSearchEngineQueueManager.php
Tue Aug 22 12:20:05 2017 [24368][1][ERROR] Unable to load custom logic file: include/SugarSearchEngine/SugarSearchEngineQueueManager.php
Tue Aug 22 12:20:05 2017 [24368][1][ERROR] Unable to load custom logic file: include/SugarSearchEngine/SugarSearchEngineQueueManager.php
Tue Aug 22 12:20:06 2017 [24368][1][ERROR] Unable to load custom logic file: include/SugarSearchEngine/SugarSearchEngineQueueManager.php
Tue Aug 22 12:20:07 2017 [24368][1][ERROR] Unable to load custom logic file: include/SugarSearchEngine/SugarSearchEngineQueueManager.php
Tue Aug 22 12:20:08 2017 [24368][1][ERROR] Unable to load custom logic file: include/SugarSearchEngine/SugarSearchEngineQueueManager.php
Tue Aug 22 12:20:09 2017 [24368][1][ERROR] Unable to load custom logic file: include/SugarSearchEngine/SugarSearchEngineQueueManager.php
Tue Aug 22 12:20:09 2017 [24368][1][ERROR] Unable to load custom logic file: include/SugarSearchEngine/SugarSearchEngineQueueManager.php
Tue Aug 22 12:20:31 2017 [21495][44bc535b-103d-dc6e-00c6-54a3d594bf4d][ERROR] Unable to load custom logic file: custom/include/social/hooks.php

Needless to say, scheduled jobs are still not running either

Maybe you need to fix those errors so that the rest can work…

Try disabling the Facebook and Twitter feeds in Admin / Activity Streams, I hear they give problems.

If that doesn’t work, you’ll have to dig in and find out where those references to custom files are coming from… did you try any customizations?

Thanks for your help so far pgr.

I’ve disabled the social connectors, but the errors are still appearing in the log. My system does not have any customisations, which makes these errors all the more confusing.