Nothing is Displayed for Install.php

First off I am running this on a Mac. I am very new to SuiteCRM and am tech savvy, but I am brand new in terms of learning code and delving into SuiteCRM. Certain aspects of our the CRM are currently live so I would prefer to work with a local copy while I am still learning. I installed MAMP and got everything up and running. I downloaded SuiteCRM 7.2.2 MAX and unzipped the files to Applications/MAMP/htdocs. I went ahead and put everything into a folder I labeled ‘SuiteCRM’. When I went to navigate to http://localhost:8888/SuiteCRM/install.php… just a blank white page is displayed and nothing else.

I have also tried not putting into a folder and just having everything inside htdocs but still nothing… so I went and opened up the php file error log and here’s what I see every time I attempt to load the page:

[12-Jun-2015 13:29:07 Europe/Berlin] PHP Fatal error: require_once(): Failed opening required ‘include/SugarLogger/LoggerManager.php’ (include_path=’.:/Applications/MAMP/bin/php/php5.6.7/lib/php’) in /Applications/MAMP/htdocs/SuiteCRM/install.php on line 53

So I’m guessing something isn’t navigating properly, but I don’t know how to fix this. Help would be greatly appreciated.

Is that file there? If it is it will be file permissions.

The file is indeed there. I don’t see any file permissions out of the ordinary, everything says read and write. Could you point me to where I could go about fixing those? Or you talking about the section on the install guide where it says too “Set ownership of the SuiteCRM directory:” … because I couldn’t figure out how to do that.

Yes that section. If you open up a terminal and use use the cd command to get to the directory then paste the commands it tells you on the guide.

I have found the guide to be about as clear as mud. For all intents and purposes, I need to know exactly what to type into terminal to change my permissions. I went online to look for the user and group set by apache. And I’ve gotten a dozen different answers…

So far I’ve got the following as being possible user and group names:

But none of them appear to work. I’ve also tried and www/data… but to no avail.

So on Terminal I type in:

chgrp _www -R

and it says:

chgrp: you are not a member of group _www

So then I tried:

chmod -R g+w _www

and it says:

chmod: _www: No such file or directory

I have tried this exact same line of code with all the different apache user and group names I listed above, and a few others… Whatever the case, I have no idea what to do to set my permissions correctly or even what in the world the default user and group is supposed to be. I went into the ‘httpd.conf’ file and in there it says:

User jshwhitlow
Group #-1

But originally it said

User daemon
Group daemon

Not sure how I changed it, but I didn’t mean too…

open a terminal, type:

cd /Applications/MAMP/htdocs/SuiteCRM

then enter these commands:

sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload config_override.php

Worked good until the last line.

Joshuas-iMac:~ jshwhitlow$ cd /Applications/MAMP/htdocs/SuiteCRM
Joshuas-iMac:SuiteCRM jshwhitlow$ sudo chown -R www-data:www-data
usage: chown [-fhv] [-R [-H | -L | -P]] owner[:group] file …
chown [-fhv] [-R [-H | -L | -P]] :group file …
Joshuas-iMac:SuiteCRM jshwhitlow$ sudo chmod -R 755
usage: chmod [-fhv] [-R [-H | -L | -P]] [-a | +a | =a [i][# [ n]]] mode|entry file …
chmod [-fhv] [-R [-H | -L | -P]] [-E | -C | -N | -i | -I] file …
Joshuas-iMac:SuiteCRM jshwhitlow$ sudo chmod -R 775 cache custom modules themes data upload config_override.php
chmod: cache: No such file or directory
chmod: custom: No such file or directory
chmod: data: No such file or directory
chmod: config_override.php: No such file or directory
Joshuas-iMac:SuiteCRM jshwhitlow$

Ended up solving the issue, when I did a search for the install.php file, it popped up inside the include folder, but what I was searching was inside the include folder from the original download, for some weird reason when I did a drag and drop it copied over everything except for that one folder, copying it over solved the issue!