Not found: InboundEmail and Campaigns (Email) require the IMAP libraries. Neither will be functional

System Environment

PHP Version 5.5.9-1ubuntu4.20
XML Parsing OK
MB Strings Module OK
Writable SuiteCRM Configuration File (config.php) OK
Writeable Custom Directory OK
Writable Modules Sub-Directories and Files OK
Writable Upload Directory OK
Writable Data Sub-Directories OK
Writable Cache Sub-Directories OK
PHP Memory Limit OK (128M)
ZLIB Compression Module OK
ZIP Handling Module OK
PCRE Library OK
IMAP Module Not found: InboundEmail and Campaigns (Email) require the IMAP libraries. Neither will be functional. :unsure: :unsure: :unsure:
cURL Module OK
Upload File Size OK
Sprite Support OK
PHP allows to use stream (upload://) OK

Switched to a new dedicated server, using a sub domain. Almost works but missing above. Tried adding php.ini w/

no change, please help?

I don’t know much about ubuntu… anyway check this-> link it might help

You can add the following line to the config_override.php

$sugar_config['allow_pop_inbound'] = true;

Check here for further reference:

I just noticed that this is a setting of the Pro version. However I remember using it with success some time ago so trying shouldn’t hurt.

No luck. Any other ideas?

still no luck.
phpinfo says imap is enabled.

php5query -s apache2 -m imap


imap (Enabled for apache2 by local administrator)

as output but still same error. should i just complete install and fix later?


been trying to get this running for over a month :frowning:

I would complete the install and check it later.

Just one note: the setting I suggested, if it works, it will only in an installed system so how could you test it without having installed the system first?

Before you install it does a system check. This is the only issue.

The setting I suggested is to use pop3 instead of IMAP. (if it works) it will only do so after you have completed installation and, in the positive scenario it works you will not need IMAP.

Hey mates i just did a new installation on a freshly installed centos 7 enviroment.
Centos 7 & PHP version 7 from ius.

The first issue I faced was similar with the permissions issue but i had to turn off SELinux
After that the imap issue you are faceing came up!
I installed the php-imap from ius repository(version 7) and then restarted the apache service.
I did a recheck on suitecrm installation screen and everything is ok to proceed!

Do you have SELinux installed? If yes, maybe you have to turn it off (at least for testing).

Simple procedure that works for me:

  1. Go to php.ini
  2. Go to “Dynamic Extensions” section and uncomment line “;extension=imap” (delete ; sign)

Works for you?

1 Like

For exact installation of suitecrm on ubuntu, please look here.