No menu bar after upgrade to 8.3

Menu is missing after upgrade.

Can please somebody send me the link to the quick repair to add it to the url?
I want to try the repair before I post all the issues.

Worked but dose not help anything.


1 Like

Thanks :slight_smile:
Repair doesn’t help.
Fix the rights doesn’t help.
PHP 8.0 doesn’t help.

Okay, so compare your instance URL with that site_url (in config.php) and check.
Are both URLs same or different?

If same, so again give file permission and clear the cache. and try again.


Thanks for information.

Instance URL and site_url are the same.
‘site_url’ => ‘’,
Apache is pointing to /public/

I also checked the RewriteBase /public/ is correct.

I deleted the cache and tried it again with no success.

Do you have any other idea?

Check suitecrm.log, php_errors.log and browser developer console for JS errors.

You need some clue to give you some orientation in the diagnostic of the problem…

suitecrm.log entries after login:

Tue Jun 6 11:34:46 2023 [4044450][1][ERROR] Unable to find relationship emails_email_templates

After clicking a meeting entry:

Tue Jun 6 11:36:58 2023 [4045312][1][ERROR] Unable to find relationship projects_contacts_resources
Tue Jun 6 11:36:58 2023 [4045312][1][ERROR] Unable to find relationship am_projecttemplates_contacts_resources
Tue Jun 6 11:36:58 2023 [4045312][1][ERROR] Unable to find relationship projects_users_resources
Tue Jun 6 11:36:58 2023 [4045312][1][ERROR] Unable to find relationship am_projecttemplates_users_resources

I can’t find a php_errors.log. Where can I find it?

There are 5 errors with the browser console. I checked the mentioned path and files an they exist. The rights are 775 for folders and 664 for files.

These are the errors:

The first file …/api/… dose not exist.

First thing, rty it without the German language pack, see if the errors go away.

Try some other repairs - Javascript repairs, language repairs.

php_errors.log is defined in your php.ini. I would advise going to Admin / Diagnostics / phpinfo and look for the logging definitions there.

You mentions the permissions you gave to files and folders, but what about the ownerships? They’re crucial. Do you know which user your web server is running under? Is it really www-data or something else? That’s the user you need to use in the chown commands.

I did set the language to English.
Clear cache, repair and rebuild. Same issue.

I did change the permissions as mentioned in: Backend-end Developer Install Guide :: SuiteCRM Documentation
" * If the group name differs from the username apache is running with, you may need 0664 instead of 0644, and 2775 instead of 2755"

The group name is different from user and the user is not www-data

There is no error in the php_errors.log.

I tried now a complete new installation using the installation guide step by step. The installation failed with the browser console error message : Error: Http failure during parsing for

I think the problem is with GraphQL.

Browser console shows: POST 502 Bad Gateway

Maybe it’s a wrong setting in .htaccess, in php.ini or in the vhost settings. Unfortunately, I don’t know what’s missing from my server. I would be very happy if someone could tell me where I have to change which configuration so that GraphQL works.

What are you using in the chown command? I’m pretty sure that is what is causing the trouble.

And what user is your web server running under?

I did set the permissions with FileZilla.

Folders 2775
Files 664

Apache is running with web164 / web164g

Permissions is not the same thing as ownerships.

Are you sure your folders and files are owned by web164 or web164g?

Yes I am sure. Here a screen shot from FileZilla

And here a screen shot from web-ftp

Bildschirmfoto 2023-06-08 um 13.36.36

Ok, I am convinced. Sorry for my insistence but I’ve seen so many people go wrong on this issue.

You’re back to trying things to configure VHost, .htaccess.

If you can get errors from the logs it really helps to focus the diagnostic. Maybe something in access.log of Apache?

Another thing that sometimes causes trouble is lack of PHP modules (imap, mbstring, xml, etc). Although these should appear as FATALs in php_errors.log…

In the php_errors.log I found this entries:

[Thu Jun 08 04:04:40 2023] [error] AH01276: Cannot serve directory /home/www/erp1/: No matching DirectoryIndex (index.html,index.cgi,index.php,index.php5,default.html,default.htm,index.htm,index.shtml,index.wml,index.html,index.htm,index.php) found, and server-generated directory index forbidden by Options directive
[Thu Jun 08 04:04:41 2023] [error] script '/home/www/erp1/xmlrpc.php' not found or unable to stat

Is this correct?
Bildschirmfoto 2023-06-08 um 14.13.14

Has anyone found a solution to this?