No Incomming Mail After Upgrade to Version 7.5.1

Has anyone else encountered no incoming email after upgrading to 7.5.1?

The Apache error log contains:
[FATAL] Job ########-####-####-####-############ (Check Inbound Mailboxes) failed in CRON run

Running cron manually produces several errors. It is hard to tell if any existed before and are insignificant. In any case, none are related to email, but it could be a cron error is aborting the whole process. I did some checking and found that the reports were scheduled for */1. This should be *. After changing the value most of the errors below were changed, and a new one appeared: email!

Failed loading /usr/local/Cellar/php56/5.6.14/lib/php/extensions/no-debug-zts-20131226/  dlopen(/usr/local/Cellar/php56/5.6.14/lib/php/extensions/no-debug-zts-20131226/, 9): image not found
PHP Fatal error:  Uncaught exception 'RuntimeException' with message 'Impossible CRON expression' in /directory/directory/www_host_tld/service/modules/AOR_Scheduled_Reports/lib/Cron/CronExpression.php:329
Stack trace:
#0 /directory/directory/www_host_tld/service/modules/AOR_Scheduled_Reports/lib/Cron/CronExpression.php(151): Cron\CronExpression->getRunDate(false, 0, false, false)
#1 /directory/directory/www_host_tld/service/modules/AOR_Scheduled_Reports/AOR_Scheduled_Reports.php(169): Cron\CronExpression->getNextRunDate(false)
#2 /directory/directory/www_host_tld/service/modules/Schedulers/_AddJobsHere.php(722): AOR_Scheduled_Reports->shouldRun(Object(DateTime))
#3 [internal function]: aorRunScheduledReports(Object(SchedulersJob))
#4 /directory/directory/www_host_tld/service/modules/SchedulersJobs/SchedulersJob.php(522): call_user_func_array('aorRunScheduled...', Array)
#5 /directory/directory/www_host_tld/service/include/SugarQueue/SugarCronJobs.php(188): SchedulersJob->runJob()
#6 /directory/directory in /directory/directory/www_host_tld/service/modules/AOR_Scheduled_Reports/lib/Cron/CronExpression.php on line 329

After fixing the report scheduler, the cron error was:

PHP Fatal error:  require_once(): Failed opening required 'custom/modules/InboundEmail/AOPInboundEmail.php' (include_path='directory/directory/www_host_tld/service/include/HTMLPurifier/standalone:directory/directory/www_host_tld/service/include/..:.::modules/AOD_Index/Lib') in directory/directory/www_host_tld/service/modules/Schedulers/_AddJobsHere.php on line 535

I found another custom/modules/InboundEmail/AOPInboundEmail.php in modules/InboundEmail/AOPInboundEmail.php and edited line 535 to match.

Problem solved.

Ok, there are no more errors, but unread messages are stuck on the IMAP server. Does anyone have any suggestions?

There are no mail errors in the Apache or suitecrm.log. However the incoming mail scheduler gets stuck with a job status of running, and is held in the queue.

mysql> select * from job_queue where scheduler_id = ‘c5cc2b3c-0274-c42d-811e-56b24e67b054’\G
*************************** 1. row ***************************
assigned_user_id: 1
id: x
name: Check Inbound Mailboxes
deleted: 0
date_entered: 2016-02-03 19:20:00
date_modified: 2016-02-03 19:20:00
scheduler_id: y
execute_time: 2016-02-03 19:20:00
status: running
resolution: queued
message: NULL
target: function::pollMonitoredInboxesAOP
data: NULL
requeue: 0
retry_count: NULL
failure_count: NULL
job_delay: 0
client: CRON8b73866b3f29da8ddcc3b2519e0a7e73:2752
percent_complete: NULL
1 row in set (0.01 sec)

Hello. I’m responding to say that I have the same exact issue in 7.5.1.

I turned off Run Report Generation Scheduled Tasks, reset the job queue, and it eventually worked. Of course, you don’t get your reports.

Out of curiosity, do you have any scheduled reports that are e-mailed?


I’m having the same issue with a fresh install (test environment before rolling out multiple instances for different customers). I turned off the report generation job and that removed that as an issue but I’m still getting an issue with the mailbox. This is the error I am getting:

02/11/16 07:08:14 [39544][1][FATAL] Job cf40990c-59fb-e100-4ae9-56bca39ee66c (Check Inbound Mailboxes) failed in CRON run

And it appears to be related to this error:

02/11/16 07:08:14 [39544][1][INFO] Query:UPDATE job_queue
SET [assigned_user_id]=‘1’,[name]=N’Check Inbound Mailboxes’,[date_modified]=CONVERT(datetime,N’2016-02-11 15:08:13’,120),[scheduler_id]=N’23021fc8-2a6e-212a-c3e9-56bc7fbd51e9’,[execute_time]=CONVERT(datetime,N’2016-02-11 15:08:00’,120),[status]=N’done’,[resolution]=N’failure’,[message]=N’Warning [2]: require_once(custom/modules/InboundEmail/AOPInboundEmail.php): failed to open stream: No such file or directory in D:\home\site\wwwroot\modules\Schedulers_AddJobsHere.php on line 535

Which in turn appears to be the following (line 535 of _AddJobsHere.php):

require_once ‘custom/modules/InboundEmail/AOPInboundEmail.php’;

However, I’ve checked and the file is there so I don’t understand what the issue is nor do I know enough yet about SuiteCRM to properly work out why it’s not working; I’ll probably re-install and see if that helps.


I have this error too on 7.5.1

Inbound email is not functional.

suitecrm.log shows the error:

Mon Feb 15 14:50:02 2016 [1502][1][FATAL] Job 9a7dcc58-c22c-5b48-c574-56c1e57a1871 (Check Inbound Mailboxes) failed in CRON run

This seems to be due to a missing file:

PHP Fatal error: require_once(): Failed opening required ‘custom/modules/InboundEmail/AOPInboundEmail.php’ (include_path=’/var/www/suitecrm/include/HTMLPurifier/standalone:/var/www/suitecrm/include/…:.:/usr/share/php:/usr/share/pear:modules/AOD_Index/Lib’) in /var/www/suitecrm/modules/Schedulers/_AddJobsHere.php on line 535

Perhaps in this version the files have been moved from /custom/modules into the main /modules, but the hard references in the code not changed? If so there may be others… is there a changelog we can check?

Bug is discussed, with solution, here:

This bug seems to be still hanging around in 7.6.4. I’m forced to rebuild schedulers multiple times per day to fix Check Inbound Mailboxes being stuck on “running.” It’s a real pain!

Currently line 535 of my _AddJobsHere.php is

require_once 'modules/InboundEmail/AOPInboundEmail.php';

…so it would seem the fix mentioned above is not the solution.

Anyone else figure this out?

Hello in another post you mentionned
“New emails, with attachments of any kind, are left unread on the mail server and the Check Inbound Email scheduler is locked in “Running.””

Take a look at your config.php file, I had the same problem and check your cron settings, once I implemented those settings it solves most of this issue.

 array (
    'max_cron_jobs' => 10,
    'max_cron_runtime' => 30,
    'min_cron_interval' => 30,

Maximum jobs per cron run.
Default Value: 10
Override Example:
$sugar_config[‘cron’][‘max_cron_jobs’] = 10;

Maximum time per cron run in seconds. Default is 60.
Default Value: 60
Override Example:
$sugar_config[‘cron’][‘max_cron_runtime’] = 60;

Minimum time between cron runs. Setting this to 0 will disable throttling completely.
Default Value: 30
Override Example:
$sugar_config[‘cron’][‘min_cron_interval’] = 30;