No HTML Email templates?

I have discovered that I can no longer create email templates in HTML? When I try to edit my previously created email templates, opening the text box shows an email template different from the one I actually have open. I can’t edit or insert my signature. Everything is just text based. What on earth is going on here? Things that worked previously no longer work! I don’t understand why I’m still using SuiteCRM. This is beyond crazy!

Can someone please tell me what is going on here? Thank you.


You can use HTML for the templates by clicking on Tools > Source Code

Where do you see Tools > Source Code? I get no such menu. I am on Linux using Chrome but I booted up into Windows to see if that was the difference. I don’t see any such menu anywhere when I edit or create an email template.

If you drag over a text box into the template editor:

How are you getting this screen? This is what I see when I edit an existing email template or create a new one.

Click the “Insert” button, that’s what makes the rest of the stuff appear.

That Insert button used to insert a variable into the editor window. It doesn’t do anything now. When I click it, it shows clicked (darker color) but nothing happens.

what version you Using?

You’re right about the “Insert” button. There is something weird going on here.

Your screenshot is missing the entire drag-and-drop block where you build the email.

I’m on SuiteCRM 7.7.6, theme SuiteR and I also don’t see that block until I press the “Insert” button. But then I see it and I can work with the template correctly.

Maybe check your logs and permissions?

Cameron, I’m on 7.7.6. My laptop is running 64 bit Linux Mint and I’m using Chrome. I’ve tried this on Firefox and even booted into Windows 7 and tried it on Chrome. Nothing. I recall the Insert button used to insert a variable into the email template editor where the cursor was. Now it doesn’t do anything for me. I definitely don’t get the kind of window your screenshot shows.

could you please try on the suiteP theme and see if it is there on that?

Might just be a theme bug

pgr, are you running Windows? What browser? I’m on 7.7.6, too. I don’t see anything in logs except for some shared PHP library not opening:

[08-Nov-2016 10:06:30 America/Chicago] PHP Warning: PHP Startup: Unable to load dynamic library ‘/opt/php54/lib/php/extensions/no-debug-non-zts-20100525/ixed.5.4.lin’ - /opt/php54/lib/php/extensions/no-debug-non-zts-20100525/ixed.5.4.lin: cannot open shared object file: No such file or directory in Unknown on line 0

SuiteP is the theme I’m using.

The screenshot you attached is of the SuiteR theme.

Could you also do a repair and rebuild?

Ok, I understand the behaviour on my machine now. The menu with all the buttons only shows when the cursor is inside the template editor block. Since the “Insert” button inserts text like $account_name and moves the cursor in there, it makes the buttons appear.

So, I don’t think I have any bugs here. I’m using Firefox on Windows. Server is Ubuntu 16.04 with PHP 7.0.

If the Repair and Rebuid doesn’t fix it, I would really check permissions if I were you, and also the browser error console - there could be clues there.

Good luck

1 Like

Ok I was looking in the Admin menu, changing to SuiteP from the user settings has totally messed up my screen now. There’s no CSS formatting or anything, just text. I can’t see any way to change the theme back to SuiteR.

I’ve done repair/rebuild several times but no change. Now I can’t figure out how to get back to SuiteR theme. This is what the SuiteP theme looks like on Chrome in Linux Mint.

Ok, I looked at the Chrome console and saw a bunch of permission denied messages. I re-ran chmod according to the install doc and it seems to be working now. Both themes show the toolbar and the insert works! I’m going to test this with my existing HTML templates. I do like the SuiteP theme! Didn’t see that one till now.

Works now after resetting permissions. How is it that permissions get messed up when upgrading to a newer version? Why not have permissions setting as part of the upgrade process at the end?

Ah, permissions. That’s the big issue that keeps haunting everybody. It’s not easy to fix.

Your case is actually interesting for this. If you have set up your Schedulers, can you please check which user your cron job is running under?

You can try commands like

sudo crontab -l -u root
sudo crontab -l -u www-data

and try other users you might know of in the “-u” option.

Do this until you find one that is running the cron.php on the SuiteCRM base directory. Normally the line looks something like this:

          • cd /var/www/html; php -f cron.php > /dev/null 2>&1

although that “cd” could be different in your case.

Than please tell me which user. If it’s root, then that would explain the broken permissions.