No content after server migration

Hi all,

Suite CRM is amazing and I’m happy to use it.

A recently migrate my website. I made a full backup of my website, including SuiteCRM (db and ftp).
I then restore the db into the new db and modified the config.php to let SuiteCRM to have access to the new db.

Unfortunately, when I want to access the index.php, no error but nothing is displayed on the screen. What I have is the grey background, Favicon and the title next to the favicon. That’s it :

What can I do to resolve this issue ?

Thanks a lot for your kind help.

Is the SuiteCRM version before the migration the same as after the migration?

Did you set your ownerships/permissions correctly before running it?

Do you see any FATAL errors in suitcrm.log or php_errors.log?

Thank you for your quick answer.

Yes, I made a copy of all files on the old FTP and paste them into the new FTP. I’m actually using the version 7.9.4 according to suitecrm_version.php

How can I do/check that point ? (I’m not an IT guy but understand a bit)

Checked, no error logged

Does the URL stay just as


or does it change to

I find it very strange that you don’t have any errors in your logs. Nothing? Are they getting written to, do you have recent messages, even if they are not FATALs?

You can check it here: [hide][/hide]

When I load this URL, it changes to: [hide][/hide]

There’s some FATAL from this morning, when I made some tests by modifying the DB user/login. I can see there for example:

Mon Mar  5 10:39:01 2018 [114833][-none-][FATAL] Could not connect to DB server localhost as oajk_acube. port 3306: No such file or directory


Yes, your connection to the DB seems to be broken. Check your credentials (do they work on mysql command-line?).

In your browser, if you set View / Page Styles / No style you can see it’s showing a “Password reset” link, maybe you can try clicking it.

There’s no more FATAL error since I wrote the correct login/password/db name/host.

About the reset password: I can see it but nothing happens when I click on the buttons (OK, Cancel or the cross).

May I reinstall SuiteCRM completely but keeping my existing DB so I don’t loose my datas ?

Yes, if you reinstall, then put in (import) your database dump, it should work.

You will only be missing your customizations (do you have many)?

You can retrieve those by copying from the “custom” folder.

I finished to reinstall completely the SuiteCRM on my website. It works now. I confirm it was a DB issue.

I still have one last issue with the database backup: I imported the backup db file into the new DB using phpmyadmin -> Import.

There’s an error after import :

SQL query:

CREATE TABLE `accounts` (
  `id` char(36) NOT NULL,
  `name` varchar(150) DEFAULT NULL,
  `date_entered` datetime DEFAULT NULL,
  `date_modified` datetime DEFAULT NULL,
  `modified_user_id` char(36) DEFAULT NULL,
  `created_by` char(36) DEFAULT NULL,
  `description` text,
  `deleted` tinyint(1) DEFAULT '0',
  `assigned_user_id` char(36) DEFAULT NULL,
  `account_type` varchar(50) DEFAULT NULL,
  `industry` varchar(50) DEFAULT NULL,
  `annual_revenue` varchar(100) DEFAULT NULL,
  `phone_fax` varchar(100) DEFAULT NULL,
  `billing_address_street` varchar(150) DEFAULT NULL,
  `billing_address_city` varchar(100) DEFAULT NULL,
  `billing_address_state` varchar(100) DEFAULT NULL,
  `billing_address_postalcode` varchar(20) DEFAULT NULL,
  `billing_address_country` varchar(255) DEFAULT NULL,
  `rating` varchar(100) DEFAULT NULL,
  `phone_office` varchar(100) DEFAULT NULL,
  `phone_alternate` varchar(100) DEFAULT NULL,
  `website` varchar(255) DEFAULT NULL,
  `ownership` varchar(100) DEFAULT NULL[...]

MySQL said:

#1050 - Table 'accounts' already exists

I can now see that all accounts are restored and well there, but the contacts are missing. Is this a compatibility issue because my backup was with the 7.9.4 version and now I’m running the 7.10 ?

Thanks for your help.

Attention - it is strongly unadvised to try and migrate data between different versions of SuiteCRM. If you have a 7.9.4 backup, you need to do a fresh install of that same version, then finish the migration, and only then upgrade.

Otherwise your data structures won’t match.

So - migration is one thing, upgrade is another, mixing the two is never a good solution.

Ok I understand.

I will download and reinstall the whole thing using the 7.9.4 version, downloaded from here:

I will let you know the results.

Ok it’s working now.

What I did:

  1. Download the same suiteCRM I was running on previous server:
  2. Install this version as a new installation
  3. Once the installation is done, connect to the database, erase the complete SuiteCRM content and Import the database backup from the previous server

Thanks for your help @pgr !

I’m glad you got it working! :slight_smile:

I made an upgrade to 7.10 using the upgrade package and the wizard… and now all of the CSS is gone :frowning:

You can check it here : [hide][/hide]

Any idea ?

Tell your browser not to use page styles, so you can browse the SuiteCRM app and go into Admin / Repair and try a few repairs there.

On FIrefox, this is on menu View / Page Styles / No Style

You can also delete your cache/themes directory, it will get recreated.

Not working :frowning:

Do I need to re-install the 7.9.4 or any idea to solve this ?

Thanks !

Do you have any FATAL or ERROR messages in php_errors.log or suitecrm.log?

I don’t have a php_errors.log file (or this one is not in the source path).

In suitecrm.log I have something from this morning, when I tried the repair function :

Sat Mar 10 09:07:59 2018 [91650][c4b133d4-1d26-cf05-b6ad-59a3c1210cad][FATAL] ERROR: rmdir_recursive(): argument cache/themes/SuiteP/modules is not a file or a dir.

Keep searching for your web server log. It might be called errors.log. Look in your Apache configuration, or whatever your web server is, and see to which file it writes PHP errors.

That particular fatal error in suitecrn.log is something I’ve seen a million times, I’m still not sure what it means, or if it even means anything significant…

Here’s the error.log :

[Sun Mar 11 19:41:15 2018] [crit] [client] (13)Permission denied: /home/clients/----------------------------------------/ pcfg_openfile: unable to check htaccess file, ensure it is readable, referer:

Does it help ?