Make a quick vote 🗳 ️How do you refer to SuiteCRM extensions: add-ons or plug-ins? Click here to have your say 👈

Next button not working during installation - License Page

Hello,

I have read several topics related to stuck in license page and permissions, I have followed steps to assign permissions to suitecrm folder, but still unable to continue with installation:

OS: CentOS with MySQL/Apache/PHP5
SuiteCRM version: 7.1.1

Actions taken:

sudo chown -R apache:apache .
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload config_override.php

Privileges are finally set like:

-rwxrwxr-x 1 apache apache 47 Mar 27 11:08 config_override.php

Error Message in browser debugger:

Uncaught ReferenceError: YAHOO is not defined.

Any help is appreciated

Thanks in advance,

Regards,

Aaron

Hi Aaron,

I have hit this problem before and the cause of the issue was the way that SugarCRM was being unzipped. Looks like you are getting the same error as I was. how did you unzip SuiteCRM?

Ian.

Thank you Ian,

I just copied the zip file to “var/www/html” and unzipped using “unzip” from CentOS.

Regards,

Aarón Díaz,

Hi,

I have the same error, i can’t continue the installation because the button next doesn’t work. Did you find an issue ?

Thanks,

Benoît Yegre

Hi,

looks like adiazs unzipped the instance using a different method which fixed the issue.

how did you unzip the instance ?

os : Freebsd 8.3
unzip SuiteCRM-7.1.2-MAX.zip -d suitecrm/

Dont understand why that would be causing the issue. is there anything in any of the logs or the browser console ?

Ian.

Error Message in browser debugger:

Uncaught ReferenceError: YAHOO is not defined.

when i click Next in the licence page

The fact that this is the only error you are seeing it looks like it could be the same issue that adiazs was seeing and that I have seen in the past. I would maybe try unziping it without the -d or even try unziping it using a different package.

From what I have seen in the past when unziping depending on how it is done depends if the YAHOO Library is unziped without being corrupted.

Hi Ian/benoit31000

In fact my problem was not solved by unzipping in a different way, my post was trying to explain how did I extract the file, I apologize if I did not explain myself correctly or if it was due to my bad english.

As a workaround I installed a CentOS Virtual Machine (Oracle Virtual Box), where installation worked fine. Once installation was complete I copied suitecrm folder and exported database dump to my server, modified config.php to point to the correct DB parameters, and got it working without problem.

Returning to my original installation, today I tried to unzip and install once again using different unzip options but I got the same issue.

Some differences I found in the environment where it worked fine vs error are:

Virtual Machine (worked ok):
mysql Ver 14.14 Distrib 5.1.73
Apache/2.2.15 (CentOS)

Server (stuck in license page):
mysql Ver 14.12 Distrib 5.0.95
Apache/2.2.3 (CentOS)

PHP Version is the same for both: PHP Version 5.3.3

I don’t mean the problem is related to these version differences, but at least worked for me in the virtual machine with those versions.

Aaron.

So far I have found 2 issues with this environment while experiencing this issue:

coworker helped me modify the js pointing to validate yahoo referenced component in the error message so the original error was skipped.

After that next button worked correctly but a validation message appeared:

PCRE Library PCRE library version: SuiteCRM needs PCRE library 7.0 or above to process Perl style of regular expression pattern matching.
Location of your PHP configuration file (php.ini):

What I finally decided was to migrate server to CentOS 6.5 which already has this required version library correct.

Aaron,

i read somewhere else that a s a last resort you can bypass this issue by modifying the file install.php

update the following block to remove the line ‘license.php’

// use a simple array to map out the steps of the installer page flow
$workflow = array( ‘welcome.php’,
‘ready.php’,
‘license.php’,
‘installType.php’,
);

Try uploading files individually by FTP instead of Unzipping file in hosting File manager

If you unzip using windows default “extract all” and then upload. Worked for me.

If SuiteCRM install file zip is ziped using a different method that is safe to extract in Linux/cPanel file manager may fix this issue

There is a small hack that will bypass the problem.

Inspect elements and locate the next button, delete the part that says disabled="disabled" and it will enable the button. Cheers

Here’s a complete code.
BTW, I am installing the SuiteCRM 8.1.0 on ubuntu 20.04 apache with php v7.3

<input class="acceptButton" type="button" name="goto" value="Next" id="button_next" **disabled="disabled"** title="Please accept license first" onclick="callSysCheck();">