Next button in Reports module is not working

Hi, I have a problem with the reports module, If I use filter date creation but using “periods” like one week or last month, it will display more than 100 records… so when I click the “next” button to see more records I can see them with no problem. The problem I’m having is that if I use not a period but Type “value” and use Creation Date higher than and less than, the “next” button doesn’t work, if I put a range of period with more than 100 records and I click next to see next page it resets the results, look image attached: what can it be? any clue? can you try to replicate this in your suitecrm and help me, please…


I think this is already fixed.

You didn’t say which SuiteCRM version you’re running…

Versión 7.11.18

Sugar Versión 6.5.25 (Preparado 344)

I also assume you’re using a supported PHP version: see matrix

Maybe it was fixed, but not in every place, maybe it’s still broken in Reports…

Try looking for similar issues/PRs on Github. Search for “pagination” or something similar

pgr look what your link says:

[SuiteCRM 7.11.x ]

Platform
Linux, Unix, Mac OS Any version supporting PHP
Windows Windows Server 2008+
PHP 5.6, 7.0, 7.1, 7.2,
7.3 (starting from SuiteCRM 7.11.5)
Web Server
Apache 2.2, 2.4
IIS 8, 8.5
Database
MariaDB 5.5, 10, 10.1, 10.2
MySQL 5.5, 5.6, 5.7

This is my setup:
my suitecrm is installed in xampp in a windows enviroment.
php is 7.3

Apache Version Apache/2.4.46 (Win64) OpenSSL/1.1.1h PHP/7.3.25
Mysql: |MysqlI Support|enabled|
|Client API library version|mysqlnd 5.0.12-dev -

1 Like