New SuiteCRM 7.11.8 installation on Raspberry Pi (finally) -- but can't login

I read great things about SuiteCRM and decided to give it a try. I just went through a weekend of setting up new SuiteCRM 7.11.8 instance on A Raspberry Pi 3B set up as an Apache2 server (yes, I know this isn’t “recommended” and will be underpowered and potentially a weak point on our network, but it’s what I have; plus it’s really just me planning to use it anyway). I am very much a novice in this, but after solving many, many individual issues over several very late nights, it finally installed and brought me to the login page. I can see with phpmyadmin that the database (and tables) were created and I can see the users and their permissions.I can call the page via the LAN or via an IP address from outside.

However, I can’t seem to login to SuiteCRM using either the Admin username/password or any other user credentials, and neither using localhost nor the LAN nor the outside IP address. I just installed it and can’t login in at all. One other issue: it doesn’t show a “reset password” option on the login page.

I tried to go through all the major issues that seem to come up from using a Raspberry Pi, including chown correctly, using SuiteP, getting the ports to work, making php.conf has been modified, etc.

The MySQL database appears to be working, and can be used via phpmyadmin or directly in the console. It’s version 15.1

PHP is 7.3 and seems to be fine.

The error logs in SuiteCRM look like (with the username and passwrod and ip blanked out):
Sun Nov 3 01:43:05 2019 [5109][-none-][FATAL] SECURITY: User authentication for xxxxx failed
Sun Nov 3 01:43:05 2019 [5109][-none-][FATAL] FAILED LOGIN:attempts[1], ip[ a. b. c. d], username[xxxxx]

It didn’t install perfectly: the IMAP wasn’t recognized so I assume I’ll need to fix the email functionality later…

I’ve read a ton of online forum responses, articles and other sources but not sure how to get into my SuiteCRM. Any thoughts are appreciated.

Thank you.

things you can try

  • checking in php.ini that your session.save_path points to a valid directory and it is writeable

  • using a very simple password without any special characters

  • resetting the password from the database:

UPDATE users SET user_hash = '$2y$10$ua6PicOvqyYMKgOR6gzFcub.Z5s40j6moWRH4oaO.Ef667lz.nb0m'
WHERE user_name = 'admin';

After that command your admin password should be


I apologize for my delay in thanking you – thank you; it definitely worked, to a degree: I can now login (and get past the login screen). Unfortunately I now get “WARN_NO_SMTP_SERVER_AVAILABLE_ERROR” . As I mentioned earlier, I never set up the SMTP email preferences as part of the installation because something was wrong with them and I assumed I could add it later, so this could be part of that? I also assume from another forum post I’ve messed up permissions somewhere to have received this error at all (and desperately don’t want to just set permissions of everything to 777 as suggested here

One other question: what are the allowed characters for passwords? – I notice one of your suggestions to me was to simplify the password to get on, but I generally prefer and more complex password.


Which of my suggestions worked?

If you’re seeing the actual string WARN_NO_SMTP_SERVER_AVAILABLE_ERROR on the screen - you shouldn’t. You should be seeing the English sentence that corresponds to that code. This could be permissions problems.

The permissions don’t have to be 777, as long as you set the ownerships right (chown -R). To find out the correct username, go in Admin / Schedulers, the crontab instructions at the bottom say your actual web server user name, which is what you should apply for file ownership.

Passwords should allow any character - if it works, you can use it. My advice was only meant as a way of narrowing down possible causes of trouble while diagnosing.

Sorry for the delay, and thanks again for the help.

To be honest I’m not sure what worked as I’m blindly staggering around this installation, and it seems debian server development is a dark art. But I think regarding this specific issue permissions were off (and that took time as I didn’t blindly assign open permissions for 777 as I am under the impression that would be a security issue) – learning how to chown properly was “an experience”. Once I figured this out I now see English sentences instead of php.

My php.ini was fine regarding save_path.

I also think changing the password to a simple passrowd (Password123) worked although I’m not sure why as I’ve since changed it to a more reasonable password and that seems fine – that was a surprisingly instant help. It worked before I solved the permissions so perhaps more complex passwords are somehow handled improperly until permission are correct?

The actual SMTP issue (which caused the error flag) was eventually solved by changing my DNS text at my CDN, and using a different server and a username which is the entire email address and not just the literal username – it just took a while to iterate changes and then see if it worked. I ended up trying it using until it worked, and then using the correct configuration in SuiteCRM.

I ran into an unrelated problem (which set back my solving the problems above) with my router randomly re-assigning a different port which took a while to figure out (as I said: blindly staggering).

And I now have another issue regarding “Inbound Email cannot function without the IMAP c-client libraries enabled/compiled with the PHP module even though I’ve enabled imap and php_imap everywhere.” but I’ll ask it as a different question.

But in general it appears most other functions work – I can import contacts, manage assignments, change paswosrds/profiles, add users, etc.