New Search Filter Not Working 7.8.0

Just installed 7.8.0 and the new search filter for leads/contacts, etc. doesn’t work. I click on the filter button and nothing happens.

The link for the new button is Javascriptvoid(0), the other new button to add/rearrange columns seems to work fine.

I did see a post where I can go back to the basic/advanced search, which I will probably do in the meantime, but I’d like to get this working. Anyone else?

2 Likes

same result here. Going to disable it for now, but I will be following this thread.

Hey Guys

Have you tried -

  • Quick Repair and Rebuild
  • Rebuild Minified JS Files
  • Rebuild JS Grouping Files

And do a hard refresh (clear all temp files from your browsers cache).
E.g Firefox - https://support.mozilla.org/en-US/kb/how-clear-firefox-cache
Chrome - Ctrl + F5

That was the first thing I tried. That didn’t help.

I even tried in a different browser (MS Edge) and it didn’t work either.

Hey Guys

We do have a file fix on Github which if you wish to apply immediately feel free to do so.

https://github.com/salesagility/SuiteCRM/pull/3035

Once applied please:

Rebuild Minified JS Files
Rebuild JS Grouping Files
If necessary Repair & Rebuild
Clear Browser cache (as you need to ensure you have the latest javascript loaded).
Navigate to a module with the new Filter functionality and Click on the Filter button.
If successful a PopUp window will appear.

There will be a 7.8.1 release with this fix included.

1 Like

Thank you!! I can confirm the fix on Github works.

1 Like

Is this not fixed in 7.8.2? I just did a fresh install of that version and still can’t use filter icon.

if so, can you please give me a little more detail on how to apply the fist. I am a moderately technical person, but I am learning CRM installation on the fly. When I go to the github link you shared, I see a tab that says 2 files changed. Do I just create those 2 JS files and then use them to overwrite the originals in the directory? and then run the steps to conduct the test, right?

I tried that and saw no effect. Am I missing something, or just completely wrong? Please advise.

Also, is there a different way to filter module records in the meantime?

I am facing the same issue, installed 7.8.2 latest version. and did repair and install but fliter and View column does not work.
Please suggest the changes

Hey, you also have to go to GitHub and make the changes to the files. Then do the repair and rebuild and this fixes it. For sure, it fixed mine.

Hi, I had the exact same thing happen to me. Was not sure what to do??? I swapped the browser from chrome to safari and it now works fine.
I thought this might help someone out there.

Could somebody point me at the option which disables the filters and restores the old search functionality? I see this mentioned here, but after much searching I can’t find it.

I’m finding filters to be more of a hindrance than a help. One problem is that a filter can’t be edited once it’s been set up, so if I make a typo I have to re-enter the filter from scratch instead being able to quickly correct the typo. Also, having to remove old filters and add new ones means I have to use more clicks to change my search criteria than was previously the case, making things slower.

I don’t know any way of disabling it, but I would suggest “Saving As” the searches you do on a regular basis. So for example if you had a regular search for leads in Chicago, status “new” you could save that and then maybe on “chicago” is the field you change on a regular basis. That would certainly save you time if you do regular searches for the same stuff and only change one field. That way you’d never have to re-enter if you make a typo.

Unfortunately most of my searches are fairly “unique” so having saved filters doesn’t help much. I’ve done some more searching and discovered that setting the parameter ‘enable_legacy_search’ in config.php is supposed to restore the original search behaviour, however setting this to true had no effect. So for the time being I’ve found the points in the code where this parameter was being read and have edited it to force the old search behaviour to be switched on.

For reference, the files are /include/SearchForm/SearchForm2.php and /include/ListView/ListViewSmarty.php.

I can’t really imagine a situation where either I or any of my colleagues would ever want the filter style searching, it’s far more cumbersome to use, so at some point I might try to decipher the logic to see why the config parameter fails, but this will do for now.

This is still not working in 7.8.8.

Could you please indicate how you edited the two files to get legacy search working?

~eric

Hi!
Better later than never… (?)
Adding this line to config_override.php will restore the old search in Contacts.

$sugar_config['enable_legacy_search'] = array('Contacts');

@geckopeb@gmail.com Thanks for that, it wasn’t clear how this parameter was supposed to work.

Setting that parameter to true ought to re-enable the old style searches for everything, but it didn’t work, in the end we just patched the code to force old style searches on in all modules.

On a side note, will this continue to be supported in future releases? The new filter +popup interface is slower to use than the old style.