New Install - No Theme?

Hi, I’ve installed Suite CRM twice and I get this result both times - Which I’m interpreting to mean that I’m doing something wrong. What can I do to fix this issue?


Have you set the permissions on your instance to appropriate values?

We normally recommend the following:

755 for all files/folders recursively
775 recursively for the folders: cache, custom, modules, themes, data, upload, and the file: config_override.php
Set the user&group for the files/folders to the webservice, (Apache / IIS / etc…), user

I.e: For Ubuntu the command for this would be; sudo chown -R www-data:www-data
(Feel free to replace “www-data” with the User / Group appropriate for your OS. For example it could be apache:apache or daemon:daemon)

Or, for windows,This is typically IUSR_[computerName] where [computerName] is the name of your computer.

If you do this, navigate to Admin > Themes
Ensure that a theme is set to “Enabled” and that a theme is set to “Default Theme”

Then, navigate to your user profile. (Click your name on the top-right)
Then, navigate to the “Themes” tab and select a theme.
Then save.

Then, finally, Navigate to Admin > Repair and select “Quick Repair and Rebuild”

Once this has finished, execute any changes if prompted.

Then, navigate to any other page in the CRM and Press CTRL+F5 to refresh Cache & Page.

Is your issue then resolved?

Never could get it working - I installed 7.5.3 and it seems to be working, I haven’t dug too deep into its functionalities. Unfortunately I am unable to upgrade to the newest version. I will try deleting and restarting with the newest version again and making sure all the folders have the right permissions on them. Thanks - I’ll let you know how it goes.


I’m trying to follow the instructions of this thread :slight_smile: ! However, it would be great if you guys can assist me with some doubts that I have…

First, when talking about permissions, it’s about the permissions of the folder where I’m storing the suiteCRM files right?, I can’t see any 775/755 options… instead I’m having this…

Second, could you confirm when I supposed to the commands that you mention? (R www-data:www-data)… I’ve read this in another thread related to the cron file, but it would be awesome to know how can I introduce these commands and where…

Third, I’ve tried going to the Themes tab and find the “Enabled” option, but is not there at my end.

Finally, I’ve tried to find the “repair and rebuild” feature within the developer tools , but I can’t find it

Kindly take a look to th attached files…

Im having the same problem and my premissions look the same as yours.

Are you on bluehost?

I’m still having the same issues with the 7.6.4 version. I’m on inmotionhosting - not sure if that makes a difference. Any ideas?

you guys need to enter in this website and calculate the correct permission stated in SuiteCRM documentation and then put them in your host configuration menu.

about file ownership I don’t know how host companies handle that part, I suggest you guys to ask them.

best regards

Hey Mike,

In regard to the permissions I just shared the screencapture to make sure that was the right element, though I set the pemissions to 775 and 755 as suiteCRM indicates in the installation page (the images shows 777 which it’s wrong indeed)

Any other suggestion to solve this “covered page” issue?


I’m on Cpanel (godaddy hosting service)


"It was indeed a permissions issue like the good people at the forums pointed to. I had to run,


from the command line for your account. Basically that account sets all the files to the permissions our server expects. I believe SuiteCRM’s install by default uses permission values our server doesn’t like."

My issue has been resolved - thanks to the incredible support of my web host. This is a direct quote from our conversation about what the problem was. They literally fixed it in <30 seconds. Hopefully this will help other people with the same issue. Your host should be able to resolve the issue in no time!

Hello eveyone,
I just talked with my hosting provider (GoDaddy) and they told me that it’s an issue that might be solved by SSH (I’m not sure what that is though)

Here’s a part of the conversation:

Agent: It seems that this needs to be access using SSH

Me: yeah, I’ve read that. I actually enabled that feature from Godaddy’s hosting manager, but after I enable that what’s the next step?

Agent: Are you familiar in using SSH? Like FTP this is a way for you to connect to your server

Me: nope, this would be my 1rst time…

Agent: This is more complex than FTP, it’s like a CMD and FTP

Me: I know how to use FTP, I’ve been doing that for years, but not SSH til now

Agent: You might want to check someone who is expert in using SSH. The cmd that your looking for seems to be the SSH access :slight_smile:

Me: I’d like to find what interface should I use, and then try to make my way from there…

Agent: It’s going to be a 3rd party application, try looking for Putty, this is an app to access ssh

I guess I’ll need to download Putty and find my way from there… any suggestions? or is there any other way (easier) to solve this installation problem?

I almost forget, yesterday other user of this forum (Mod, should we merge threads?) adviced me to run a “system check” by accessing the Admin page using firefox with “no style” for “page style”, something like this

As you can see the SuiteCRM’s system check says that All the Required setting are available (privileges + permissions)

So now what can it be???


I am on Bluehost and had the same trouble. I tried using the file manager to change the permissions but it didn’t change them. I ended up going into my account via SSH and manually changed the permissions with chmod to what John said earlier:

755 for all files/folders recursively
775 recursively for the folders: cache, custom, modules, themes, data, upload, and the file: config_override.php

I don’t know why the file manager from the control panel didn’t do it, but I fixed it before I tried other options in the control panel.

Hello tazagul,

Thanks for sharing your experience… one question… do you know what would be the command for a Linux OS (godaddy hosting)
I’m having command errors when trying to change permissions using John’s method (I’ve read his post, but I guess I don’t completely understand the format)… check this out

Sorry if this is a dumb question folks, but I’m not that tech savy… only trying to get suite CRM running in my site.


do these commands…

cd public_html/suitecrm
ls -al

… and post the results here. We need to find out which user your web server is running under, the ones you tried aren’t working (www-data etc). You can also ask your provider for that information.

Hello pgr

I entered the 1st command succesfully, but for the 2nd [Is -al] I’m having an error… this is what I’m having…

I also asked to my hosting provider and they tell me that “they will send me an email” :sick: because to allow me to run that command I need special access or something like that … here an extract of the conversation… (with godaddy)

[i]Me: which user and group my web server runs under?..that’s the main question

Me:I need to run a command through SSH, those are elements that I need to do so, otherwise it shows errors

Godaddy: Thing is that command is not permitted with us we would have to check with a higher tier for that one. Permission will have to be granted for that command.

I’m starting to think that my hosting provider is not that good, so hopefully I can solve this issue with the help of the folks within suiteCRM forum


No wonder you can’t run the command, that’s not a capital-I, it’s a lowercase L. The command is LS -AL in lowercase.

But forget it, if you don’t get access to run these commands as sudo then your only chance is to get your provider to do them, or host SuiteCRM somewhere else where you get more control.

Try asking them to run these from your suitecrm root folder:
sudo chown -R user:group .
sudo chmod -R 755 .
sudo chmod -R 775 cache custom modules themes data upload config_override.php

(replacing user:group with the user under which your apache server runs, and it’s group)

1 Like

Any suggestions about a hosting that’s compatible with suiteCRM (if affordable and easy to use would be awesome!)


Sorry, I’m hosting my own server, I don’t know of any hosting services I could recommend.

I know SalesAgility themselves have hosting services. Probably that’s a premium service (because they know SuiteCRM better than anybody, and their service is specific for this), but ask them for prices.

Search these forums, every once in a while somebody asks that question and a few suggestions come up.

It’s not just a matter of “compatibility” with SuiteCRM, they’re all compatible, what matters (and makes the price vary) is

  • how much control/access you get (are you root? can you set permissions by yourself? at least in your area?

  • how much control/reliability you have over your data and backups, and disaster recovery procedures?

  • SuiteCRM has an additional stumbling block for many hosting services: the upgrade processes are heavy and some hosting providers don’t handle them very well. So some people are stuck with systems that work fine but can’t be upgraded.

Hey PGR,

I see… :unsure: then I’ll try installing suiteCRM in my PC… after going through all this process I think it would be easier for me…
In that regard, I’d like to say that I’ve tried once by downloading the software pack, unzipping and then copying the whole folder to my C drive
Nevertheless, after doing so. I tried to open the installation.php file but my browser shown a page with a bunch of code that look like this:

I guess I’m doing everything wrong :silly: , but… I’d like to get suiteCRM installed somewhere and if you can share some thoughts about what do you think I’m doing wrong in the PC installation would be really helpful so I can start finding my way within this forum from there.

Btw, I have a Win 7 PC… my main questions is how to know my server name… I’ve tried using 'c:/hostname´+ the file route, but my brower shows a “file not found” message


I don’t know much about installing on Windows…

Anyway your local server name is


which is the same as

This is true for Windows, Linux and others. It’s a common convention.

There are ready-made SuiteCRM servers provided free by Bitnami. I use the one in a Virtual Machine, and I can run it inside Windows (I have Hyper-V - see if you can activate Hyper-V in your Windows if you want to try it).

The Bitnami machine comes as a VMWare format, but it’s easy to convert to Hyper-V (google it). Or you can just install the free VMWare Player and run it. You need to have a fair amount of free RAM (I’d say 2 or 3gb for the VM just to develop and experiment).