Need urgent help on Facebook Integfration

I am on the following SuiteCRM version:
Version 7.11.13
Sugar Version 6.5.25 (Build 344).

I am getting the following error message when I click on the FACEBOOK LOGIN button in suiteCRM:
“URL Blocked: This redirect failed because the redirect URI is not whitelisted in the app’s Client OAuth Settings. Make sure Client and Web OAuth Login are on and add all your app domains as Valid OAuth Redirect URIs”

The Client and Web OAuth Login are already ON.
My question is what do I specify for the “Valid OAuth Redirect URIs”?

Thanks in advance for your kind assistance.

Hi, welcome to the Community! :tada:

Are you using any add-on from the SuiteCRM Store for this? Or are you talking about the options found in Admin / connectors?

Did you set all the options there?

Thank you for your response.

I am talking about the Admin -> Connector. Not using any add-ons for the moment.

Yes, all the fields are set in the Connector - Facebook App ID and App Secret are already set correctly. The Leads module has been enabled for connector. However the “Map Connector Fields” is coming up as blank.

I was able to get around this problem by using the following OAuth Redirect URI in the Facebook Login -> Settings :

However, now I am getting the following error now:
"Invalid Scopes: read_stream, publish_stream. This message is only shown to developers. Users of your app will ignore these permissions if present. Please read the documentation for valid permissions at:
I found that both the above mentioned scopes are long deprecated by facebook. Not sure how to proceed from here.

As far as add-ons are concerned could you please point me to the same - I could not find an add-on for Facebook?

Have a look at this, it seems to be a known issue, but I’m afraid it’s been there a long time and no one worked on it :frowning:

Thanks for your reply.
Could you please point me to an add-on that I might use instead

If you don’t find it in the SuiteCRM Store, I’d say it’s safe to assume one doesn’t exist.