NaN.NaN in Quotes

Have uploaded all products to Products Module but when it comes to doing a Quote or Invoice all prices show NaN.NaN ie not a number.
All fields are correctly filled in on the template file

Sorry, meant to ask if anyone knows a solution or a setting I need to change - thanks

Similar thing happening to us with a SuiteCRM 7.10.4 / LAMP standard installation.

Product price shows up correctly when viewing and editing the product, but when lookup of the product completes in a quote, all the fields (but “name” and “part number”) are showing “NaN”.

[color=#880044]ONE IMPORTANT THING:[/color] we are NOT using US DOLLARS (default currency) as the imported currency. That could be one of the issues (just worth mentioning).

Just to be more specific: we don´t use categories (fields [category] and [aos_product_category_id]), both are NULL in our case. So are [cost] and [cost_usdollar].

Any help much appreciated !

I worked out you MUST include the currency code eg GBP or EUR etc, then the fields will populate correctly.
What I haven’t worked out is that you cannot use a different currency in the cost_currency field for example, as the system won’t accept it.
Quite why the developers don’t address such an important point is beyond me.

One of the guys here confirmed that if you import products in any currency other than USD, it will create problems.

So it’s related to your solution!

Thanks for the update, will proceed as instructed then.

Fell free to further contact me in any case ok?

All the best!

Just a couple of hypothesis

  1. They’re busy doing something else in this app with over 1.5 million lines of code, most of it inherited from a different company

  2. Maybe nobody has even reported the Issue on GitHub, so they don’t know about it

Where did you entered the currency code to solve it?

I have it all correct in administration/locals panels and the import file has the EUR stated in “Currency” column. Still dose not work.


I was having the same issue and found that if you went into any product record and saved it, that it solved the issue so I created a simple workflow that went into each record and saved the cost price and sell price as themselves and it resolved the issue

In which version are you guys still seeing this problem? I wonder it isn’t fixed already in the latest versions…