My SuiteCRM has "Notice: Undefined index: current_user error" everywhere and its stopping me from accessing some features

Im running SuiteCRM locally: Windows 7, Apache, PHP 7.x, MySQL, SuiteCRM 7.8.11.

Throughout the application, and before the page loads, I see “Notice: Undefined index: current_user in C:\Apache\htdocs\SuiteCRM\include\TimeDate.php on line 273”

Here is what the error looks like on the Studio page:

It happened after I tried adding a datetime field to the Employees module in Studio.

Things I tried so far: deleting the new field’s column in MySQL, Quick Repair & Rebuild, and going to a previous commit in Git.

Did you reply to the wrong thread? I don’t understand how this stops the error popup I get when I try to access Studio.

Please check the error reporting in code.

It seems like you have opened the “error reporting” for SuiteCRM.


1 Like

Thank you, Im happy I can access what I need to now, but it feels like I am just sweeping a problem under the rug, lol

This is almost a “must have error” when you install or update it, I have no way to explain it to you, but my solution found in the .httacess file is the cause.

  • hint: if you have used a Suitecrm source, you should review the old and new .httacess file, compare and remove redundant components. - DONE

Add the # in the following lines:

#    RewriteRule ^cache/jsLanguage/(.._..).js$ index.php?entryPoint=jslang&modulename=app_strings&lang=$1 [L,QSA]
#    RewriteRule ^cache/jsLanguage/(\w*)/(.._..).js$ index.php?entryPoint=jslang&modulename=$1&lang=$2 [L,QSA]
#    RewriteRule ^cache/jsLanguage/(.._..).js$ index.php?entryPoint=jslang&module=app_strings&lang=$1 [L,QSA]
#    RewriteRule ^cache/jsLanguage/(\w*)/(.._..).js$ index.php?entryPoint=jslang&module=$1&lang=$2 [L,QSA]

This is the complete fix for the .htaccess bug:

That’s a good way, thank you so much !