Moving our directory to another server causes issues

I zipped up our SuiteCRM directory for 7.5.1 and then moved it to our new server, unzipped it, then changed config.php to include the new information to connect to our database which is still on the other other server.

I started looking through things to make sure everything was in good order.

So far I have found:
-I cannot access the index page of the Administration panel

In the chrome console I’m getting 404 errors:
-/cache/jsLanguage/Home/en_us.js?v=YNvbbvYcCgtK50KJu040zg Failed to load resource: the server responded with a status of 404 (Not Found)
-/cache/jsLanguage/en_us.js?v=YNvbbvYcCgtK50KJu040zg Failed to load resource: the server responded with a status of 404 (Not Found)

If I navigate around to other pages, I find that the language files are also not loading. I obviously checked immediately for permissions issues.
I have the following permissions:

755 775 775 644

I have also tried applying 775 and 755 to ‘en_us.js’ as well, with no change.

The ‘Home’ folder has the permissions 775

The Dev Server is running PHP 5.4.25, and the new production server is running 5.6.26.

Any help?


I had renamed the main folder and didn’t realize that would cause an issue

I found an answer to help me out with file permissions in:

However, the Administration Panel is still showing up blank. No PHP errors even with Display errors = On and E_ALL.

I checked the PHP error log in usr/local/apache/error_log as well as suitecrm.log and sugarcrm.log to find no errors.

Have you checked your .htaccess file inside the SuiteCRM folder. It contains a reference to the SuiTeCRM folder therefore if you have moved it, the reference may be wrong.

You may also have a look here:

1 Like

That solved my issue, when I ran the beginning part of the installer, it showed me that it was using a different php.ini file than what I thought was being used, which then in turn showed me it was in fact an issue I had thought of previously.

My php memory limit was set to 32M, so I increased that to 128M, and then I was good.