ModuleBuilder: You do not have permission to access this module.

Hi, I have upgraded from SugarCRM to SuiteCRM, but Im unable to access some of the admin functions.

I managed to run UpgrageWizard by disabling this functions:

     * If there is no action found then display an error to the user.
    protected function no_action()
        sugar_die(sprintf($GLOBALS['app_strings']['LBL_NO_ACTION'], $this->do_action));

     * The default action handler for instances where we do not have access to process.
    protected function no_access()
        $this->view = 'noaccess';

As for ModuleBuilder, event after i disabled the noaccess function, I still cant access it. it displays empty page.

Any way to enable those modules the right way ?

Sorry, can you explain a bit better why you had to disable in order to upgrade?

I would focus on getting the upgrade to run completely (solving whichever problems you need to solve), otherwise you will never know what is missing from your system.

Any way, the empty page should be leaving an error in one of your two logs:


Previous programmer who sets up my company’s SugarCRM disabled some of the admin functions such as UpgradeWizard and ModuleBuilder. The only way I can migrate to SuiteCRM is by running the UpgradeWizard. So to access to UpgradeWizard, I had to disabled the two functions I mentioned.

I have tried searching inside the source codes that marks noaccess to UpgradeWizard but couldn’t find any.

I dont want to setup a clean SuiteCRM and manually insert database.

Try this:

  • log in to SuiteCRM

  • paste this URL directly into your Browser’s location bar (replace with your actual domain):