Module Loader blocked by Suhosin

hello. I can’t upload modules or language packs, having this error on the page:

Module Loader
Upload stream is blocked by Suhosin, please add “upload” to suhosin.executor.include.whitelist (See sugarcrm.log for more information)

in the logs, i have one single error, refering to Suhosin:

Wed Aug 27 20:04:29 2014 [624135][1][FATAL] Suhosin blocks all streams, please define upload stream in suhosin.executor.include.whitelist

i thought would be solved inserting the exception in php.ini, and i asked the hosting service to configure this. actually they did before for sugarCRM, and it worked. But not now. Anyone has any idea? Or an instruction for me to give them?



Follow the following steps:

  1. Go to /include/upload_file.php, public static function getSuhosinStatus(), change $configuration = ini_get_all(‘suhosin’ , false);
    $configuration = ini_get_all(‘suhosin’);

  2. In /modules/upgradewizard/uw_utils.php, in the condition if (UploadStream::getSuhosinStatus() == true) change $ret[‘error_found’] = true;
    $ret[‘error_found’] = false;

1 Like

this is the line that needs to be added to your php.ini

suhosin.executor.include.whitelist = "upload"
1 Like

sid, your solution worked like a charm. chrisharney, i never had a chance to try yours, but thanks for the input. Actually that may be safer and compatible with updates. Then again, i hope this kind of stuff gets resolved in the next version.

thanks to all of you!!

Hello Sid ,

Kindly help i cant locate $ret= true on this file /modules/upgradewizard/uw_utils.php,

As sid pointed

  1. /include/upload_file.php the change must be done at row 586

2)/modules/upgradewizard/uw_utils.php the must be done at row 1161 -> change

$ret['error_found'] = true;


$ret['error_found'] = false;

this worked for me at version 7.6.4.

Well well, my first problem appears after 5 minutes after first install :dry:
I really hope this kind of problems is not common for this software because it looks like a nice piece of OpenSource.

To fix this problem I changed the two lines. It had a short succes, because I could upload my language package. After uploading the MODULE LOADER left blank.
Any one who knows how to fix?


I am getting the same error. The odd thing is that I installed SuiteCRM in two other hosting site and did not get this problem but I installed in this current site and i get this problem. I am using SuiteCRM version 7.9.4. The worst thing about the solution provided below cannot be applied for version 7.9.4 because the files /include/upload_file.php and /modules/upgradewizard/uw_utils.php do not exist.

I am so disappointed that the developers do not even point us in the right direction. They seem to be watching a show!

These files you mention exist in 7.9.4.
Check the compressed file you downloaded.

In file upload_file.pfp there is no row 586 ?!

This has been changed.
The old upload_file.php had 828 rows

Current upload_file have 45 rows, and only requires the UploadFile.php
The function getSuhosinStatus() has been transferred to the include\UploadStream.php file at row 62

Hi, I currently have the Version 7.10.7 version of suitecrm installed and I have done all the steps that I have found and I have not yet been able to unlock the module loader in order to translate the CRM into Spanish.

php.ini = I already modified it
UploadStream.php = I also modified it

but it’s still showing up: Upload stream is blocked by Suhosin, please add “upload” to suhosin.executor.include.whitelist (See suitecrm.log for more information)

could you help me?

Same problem.