Module Builder page is blank having worked previously

Having worked fine previously I now get a blank screen for Module Builder. I’m running version 7.11.18.


Check permissions:


Checked and set as per instructions…but still getting the same result

Clean cache of browser.

No effect. Issue exists on multiple browsers. From what I can see it’s only the Module Builder page that has a problem. Clicked on everything else in the Administration section and all seem to work.

Check both your logs. There are two. You really need to check the PHP log, not just the suitecrm.log.

1 Like

That fixed it. Thank you.

Needed to do what you mention in your link:

Uncomment “error_log = php_errors.log” in my php.ini file, which in my case was found in /etc/php/7.4/apache2

Reproduced the blank page error and saw this is in php_errors.log:

[27-Feb-2021 21:43:59 UTC] PHP Parse error: syntax error, unexpected '=>' (T_DOUBLE_ARROW), expecting ')' in /var/www/html/custom/modulebuilder/packages/custompackage/modules/submission/metadata/subpanels/default.php on line 20

Removed the offending line and we’re back in business.

1 Like

I note that you’re using PHP 7.4, which is not supported yet.

It is known to bring problems, so I really advise a downgrade to 7.3.

Noted. Thank you for the link