Module Builder Broken - Suite 7.1.4

I cannot use the module builder once upgrade to 7.1.4 was completed.

I had the issue with 7.1.2, later the update to 7.1.3 fixed the issue. Now with the recent upgrade it is broken again.

The Symptom: I cannot create a custom Module in Module Builder. It allows me to create a package, Once i attempt to create an actual module it does not create. If I go back to package it shows it is created but as a basic module. Once I enter the module under module builder I cannot make any changes until I save a “Label”. Label will not save. I tried for a moment setting my permission to 777 in case that was in issue so it is unrelated to that.

Anyone have a clue as to what the issue is. I tried turning on error reporting but now there are so many errors its too much to sift through.

I will check the sugarlog and see what comes up when I attempt to create a module.

Any help would be greatly appreciated. I wonder what was changed from 7.1.2 to 7.1.3 to 7.1.4 to have this issue.

Thanks again, Love how the community is growing here :slight_smile:

I did also switch servers…So let me check and compare to my old server, this could be simply permission issue. I will report back.

Ok, so it works on my test local install on CentOS 7

I have it on production on a plesk server CentOS 6.5 (i am managing) and the issue seems to be with this, I wonder what I can do to get it working. Its probably a permission issue although I gave all the files correct permission it seems, I wonder what weird plesk setting is messing about with creating custom modules in Module Builder

I had a similar issue. It was related to PHP, although it did feel like a permissions issue. Downgraded to PHP 5.3.10 and it all worked again. Good luck.

I have seen this before and it tends to be permissions on a plesk run server.

you can update the permissions and the config.php file and all should work as expected as long as you get the right permissions in the config file.

The config for the plesk instance I used prevously which as far as i am aware is still working as expected.

array (
‘dir_mode’ => 1517,
‘file_mode’ => 420,
‘user’ => ‘’,
‘group’ => ‘psacln’,
),

Cheers

Thanks for the help, but sitll a no go. Its odd because if I set the permissions 777 it still doesnt work. So something else is conflicting with my install. On my local test server, that i used while I redid my main server, I am running centos 7 with php 5.4 so its not the php version.

I have a Plesk setup with CentOS 6.5 and Plesk 12

I knew I would run into issues with it. It is why I originaly had the server manually configure on my own but now i need easy site and email management and my dedi comes with plesk for free so why not. I’m sure someone else around here has gotten plesk to play nice with suite. I’ll dig through the php settings and see if something with the site specific php settings in plesk intefere with module builder.

It is very frustrating, the same suite install runs fine on my test server. Yet on plesk it acts up. I’m curious to maybe simply setup my own separate vhost area for suite and see if that works. But it would be nice to have it all play well with plesk.

Thanks for the help. I tried btw the above suggestions, setting dir_mode etc and it still has the same issue.

Will report back with any updates.

The only other thing I can think of which could cause a issue would be the PHP support in the Host settings for that domain making sure that it is set to FastCGI application, I had problems setting up SuiteCRM on anything other than FastCGI

regards,

Ian.

Try clearing your SUID and GUID permissions (0777). I also had this a while ago. Took me forever to work it out.

I, too, cannot change labels in Module Builder since the upgrade to 7.1.4.

If I inspect the page using Chrome’s “Inspect Element” feature, I am seeing the following every time I click on “Save”.

Request URL: https://crm.mydomain.com/index.php?to_pdf=1&sugar_body_only=1
Request Method: POST
Status Code: 500 Internal Server Error

There is of course a lot more to the message than that, but I am not sure what’s relevant. Anything else that I can try? My log file does not appear to be giving any errors or warnings.

Bump? This is a really annoying bug because it has halted the development of two modules that I’d been hoping to complete by the end of the year…

For what it’s worth, I don’t think permissions are the issue. I’m running on Windows/IIS, and even when I grant full “Everyone” access, the problem persists. It was not present until after the 7.1.4 upgrade.

Hi Rogquefort,

is there anything in the IIS logs or even the SugarCRM log ?

Unfortunately not. The only thing I’m seeing when “Debug” logging is the standard “xyz.gif missing” messages.

IIS isn’t reporting anything strange at all.

I take it that this is not happening for you in 7.1.4, Ian?

Roguefort,

I was getting the : 500 Internal Server Error on high load scripts with SuiteCRM I extended the memory limit and the execution time of the server slightly and I have not seen it since. however this was pre 7.1.4.

I was also getting the normally errors which pointed to memory and execution times.

I have had no problems with permissions.

on this I run mostly on Linux builds. so it might be changing the memory/execution time might improve the problem that you are seeing ?

unfortunately this might be a case of trial and error to get to the bottom of.

I dont know if anyone else has had a problem like this which relates to IIS ?

Ian.

Soapbox moment !
This is one example of why Suite needs to add in some better error reporting.
To improve the quality of Suite to become world’s #1 best CRM app, there should be a fully explained error message in the logs, and in an screen pop up, that details exactly why the failure occurred.
Bonus, include a link to the page on the Suite FAQ, that shows how to fix it, step by step.
Users and admins shouldn’t have to resort to trial and error for weeks, to solve basic bugs!
Nothing’s perfect, but adding better error reporting will make Suite more and more perfect…

I’m also getting the same error with an upgraded installation of suite 7.1.4 on linux/apache with nothing in the error logs:

http://xxxxx.com/index.php?to_pdf=1&sugar_body_only=1 500 (Internal Server Error)

I tried it on a clean install of suite 7.1.4 and it worked fine. So it’s not php. I also know it’s not a permissions issue because I reset everything and got the same error.

I think it has to do with the language files. I stumbled across this by accident but when I load the Languages section in the admin, the page renders fine but I don’t have any languages listed. Also, when I look at the files created by module builder, it’s only able to create the following file custom\modulebuilder\packages\custommods\modules\test\language\es_es.lang.php. I think it’s failing on the russian language file. Anyone have a suggestion on how to handle this? Or already found a fix?

Well it’s still broken for me, too. It’s pretty much halted my development of any custom modules, though it’s not like I have the time to work on them this time of year anyway.

I’m not positive that it’s a language issue; I’m not experiencing the same thing you are. My languages are listing correctly.

Remember that critical patch from a couple of months ago that was actually pushed out by the SugarCRM devs, and merged into SuiteCRM? This started happening after that. If I remember correctly, it was the patch that fixed bash. Perhaps something was removed that the module builder is actually still trying to use?

I don’t know anything about that critical patch. Like I said, I did a clean install and everything works. My development & production instances were upgrades, so I think something must have occurred during the upgrade process to break it.

Upon review (don’t know why I didn’t notice this earlier), I do get a console error in the language admin section “index.php?module=Administration&action=Languages&view=default:679 Uncaught SyntaxError: Unexpected token ;” and if I view its details I get this: var disabled_modules = ;

I don’t know if it’s related to the module builder issue, so I will create a separate post for it.

I fixed my issue. It was indeed a Russian language file causing the problem. The file custom/modules/ModuleBuilder/Ext/Language/ru_ru.lang.ext.php has a parse error in it. I overwrote that file with the one from a fresh installation and I can now create custom modules through module builder.

1 Like

THANK YOU!!! This fixed my problem too, which is strange, because I had Russian languages disabled. Regardless, I’m super-excited to finally fix this problem that I’ve had for months!

I suspect this is a side-effect to what some of us were seeing over here, too:
https://suitecrm.com/forum/suitecrm-7-0-discussion/684-unable-to-edit-dropdowns

For anyone else that wants to give this a try, I’ve attached a clean copy of that language file to my post. It doesn’t exist in the SuiteCRM download; I actually had to go through the setup process first. So hopefully this saves you some time.

Thanks again, @staganyi !

Congrats.

This problem (a modified file, causing a parse error) would probably be solved much faster than a few months, with checksums for each file. Suite would be able to easily detect when a file is different from the original one from a fresh installation, because the checksum is different. And automatically display to the admin a list of which core files are modified, to help locate possible causes of serious runtime errors.