Module Buider Broken

Doing normal product’s module customization (adding some custom fields) suddenly ModuleBuilder got broken and nothing else could be made. See image attached!

I have tried:

  1. disabling AJAX for ALL the modules and also adding $sugar_config[‘disableAjaxUI’] = true; to my config_override.php.
  2. Deleting all the files under /cache/modules and /cache/smarty/templates_c
  3. Overwriting /modules/ModuleBuilder of the broken instance with the files from a suite’s installation zip.

Any extra idea?

Have you done a repair and rebuild?

What were you doing in studio when that happened?

I was customizing Product’s module fields, just that!
I have also made a Quick Repair and run all the JS related reparation tasks.
Also tested from different browsers and in chrome private’s mode!!

If you are able to send me an email I will give you access to the server to see!


I am having the exact same issue – I cannot run a custom module. I have tried several different approaches now. I did not try to create a custom module under 7.7.9, and I did install the upgrade to 7.8 this morning.

Server: Windows 10 Enterprise w/plenty of memory