Module and customization migration from DEV to PROD - what's the right order?

Hello!

We encounter problems with moving one of our custom modules to production (SuiteCRM 7.7.4)

I’ve made module export file (Admin > Module Builder -> Publish), then exported studio customizations (Admin > Studio -> Export Customizations)

Then I’ve imported and installed module file, then customization.

All was according to http://support.sugarcrm.com/Knowledge_Base/Module_Loader/Migrating_Customizations_Between_Instances.

Now I can see our module in menu, but, if i click on it, it appears to be only with basic fields, no customizations.

I’ve tried to make a Quick Repair then. It was finished succesfully, but after that, when I try to call our module from menu, I’m getting an error.

/var/log/apache2/crm_error.log:
[Mon Oct 30 16:12:01.676713 2017] [:error] [pid 3183] [client 10.1.27.111:38455] PHP Fatal error: Smarty error: [in cache/themes/SuiteR/modules/clm_claims/SearchForm_basic.tpl line 105]: syntax error: unrecognized tag: $fields…name (Smarty_Compiler.class.php, line 446) in /var/www/crm/include/Smarty/Smarty.class.php on line 1094, referer: https://10.1.11.52/index.php?action=ajaxui

What I’ve done wrong? Where to look to fix this error?

Any help will be greatly appreciated!

Thanx in advance

That double dot in “$fields…name” is, I believe, and old bug. It is already solved, but you’re running an old version.

There was a similar case here:

https://suitecrm.com/forum/developer-help/15170-syntax-error-unrecognized-tag-fields-name

In another place someone says this

So the first thing to check is how your custom fields appear in the table fields_meta_data in the old server, and transfer that to the new one.

1 Like

Thanx for reply!

I’ve seen that topic already and checked field_meta_data table. It seems, however, that there are no differences between our old and new instances there for my module…

When you do the Quick Repair and Rebuild, if you scroll down to the bottom of the screen, do you get a button to sync database with vardefs? If so, press it.

1 Like

Tried it, unfortunetely, no button :frowning:

I’m sorry, I’m running out of obvious fixes.

Maybe this can help if you really need to go into full debugging mode…

https://pgorod.github.io/Audit-File-Accesses/