$mod_strings.LBL_LOGO when changing the logo


I get an error $mod_strings.LBL_LOGO after saving an image to replace the default logo under system settings. How does one overcome this challenge.

What is your SuiteCRM version?

If you’re not using the latest, make sure you try with a Logo file that does NOT include a space in the filename, there was a bug related to that.

Also, did you set your ownerships/permissions correctly in Linux? Do you see “undefined” labels on some random screens?

I am using version 7.11.8

I just changed permissions to 775 and yes I do get the “undefined” pop-out screen

The challenge still persists

Permissions only meaningful with the accompanying “ownership” settings (chown command).

Do you have SSH access to your server?

If you go in Admin / Schedulers, what do the instructions at the bottom say, exactly?

Note instructions below

In order to run SuiteCRM Schedulers, edit your web server user’s crontab file with this command:
sudo crontab -e -u m4lb7qfchj50
… and add the following line to the crontab file:

          • cd /home/m4lb7qfchj50/public_html/kgoleholdings.co.za/pallife; php -f cron.php > /dev/null 2>&1

I am on a shared hosting platform so I created a cron job on the cPanel with the command below

/usr/local/bin/php7.2 /home/m4lb7qfchj50/public_html/kgoleholdings.co.za/pallife; php -f cron.php > /dev/null 2>&1

Please advise if it should be in order

Did you use this for the chown command?

chown -R m4lb7qfchj50 .

Then run a Quick Repair and Rebuild.

The idea is to make all files owned by the same user name that your web server is using to run.

Your cron command doesn’t look correct. Maybe something like this

* * * * * cd /home/m4lb7qfchj50/public_html/kgoleholdings.co.za/pallife; /usr/local/bin/php7.2/php -f cron.php > /dev/null 2>&1

… IF that is in fact the correct path to your PHP executable. You can ask you hosting provider if it is.

We have the same problem, but on Windows (Xampp) basis. Even after updating the same bug. A logo cannot be added.

The path is indeed correct and I have created a cron for chown. The problem still persists even after quick repair and rebuild


In Admin / Schedulers, if you click to go inside a job, do they ALL show as “Last ran successfully: never”? Or can you find at least one that ran recently?

If none of them ran, please ask your hosting if the entire Crontab setting is correct or not. I can’t guess how each hosting wants it done. If it is correct, they should be able to confirm to you (from their logs) that the file is being called.

I was advised to enable shell access in my cPanel. Then I was able to ssh into the web server to write commands for permissions and ownership. It seems to be working just fine now.

Thank you for your patience and assistance

No problem, I am glad you got it working!

2 posts were split to a new topic: Error uploading logo on Bluehost