Missing wysiwyg editor for Creating Email templates

When i try to create a email template the wysiwyg editor for the body section is missing.
When I try create a pdf template using the top right create button in the pdf template page the wysiwyg editor is missing, only a text field is there in this instance. but If i use the create pdf template link located on the shortcut panel on the left, the wysiwyg editor shows.
SuiteCRM Version 7.6.2
Sugar Version 6.5.23 (Build 1061)

Apache version: Apache/2.2.27
PHP version: 5.6.14
MySQL version: 5.1.73

Possibly it’s a permissions problem.
Please search the forum for permissions and set permissions appropriately then go to Admin->Repair->Quick repair and rebuild
Possibly you should also try repairing the javascript files: look in Admin->Repair

After you are done refresh your browser cache and try reloading the page. Possibly you may have to log out and re-log in

Additionally you could check both yuour PHP/Apache logs as well as your SuiteCRM logs

1 Like

It was a permission issue, thanks.
i used the following as a guide to setting permission

we checked the permissions and they were set correctly based on the email string below. we are still missing wysiwyg editor on the email templates. Any suggestions?

The following might work a little better
replace /home/path_to_suitecrm in the code below to the actual path of your suiteCRM installation

find /home/path_to_suitecrm -type f -exec chmod 644 {} +
find /home/path_to_suitecrm -type d -exec chmod 755 {} +

if your still having problems it might be a user premission problem, Give the correct user permission to the suitecrm installation directory by using the following command (change “user” to the actual user of suiteCrm)

chown -R user:user /home/path_to_suitecrm 
1 Like

thank you Rasheid. we will try this fix.

Hi, Did this tip fix the issue for you ?

Yes, thank you. It did fix the issue.