Missing REMOVE button from subpanel


after update 7.8.X -> 7.10.22, I am missing a REMOVE button in all subpanels.
I have checked layoutdef files and everything looks fine and correct.

I tried adding extra button, and this works. Looks like some parser is blocking remove button.

Does anyone know where to look next? I can not find where is HTML created for buttons.

Best regards,

Is it in English or a different language? Maybe a problem with the labels?

You can check this by logging in with a user that uses English language.

Any language it is the same.

There is not button on page, source code of page (HTML) doesn’t have button; I am missing


element for button.


I think it’s coming from the widgets here

The ones mentioning SubpanelRemove

Have a look in your custom folder, are there any files overriding this?


custom folders are all ok. This is fine, but I belive that somewhre else is the probelm; because REMOVE button is not shown, so some parser/template part of code is not showing it.

Only problem is that I can not find code that reads subpaneldef files and constructs HTML for page.

The code? It’s simple:

(hint: I am using irony :smiley: )

Thank you for help, but irony it is.

I am reading this and I am still nowhere :pensive: :pensive: :pensive:

But I have to go on I need to solve this.

I am comparing this project with other that is working and can not find a single thing different.

Just that my HTML is missing REMOVE button.

Mine - missing

Have you tried setting breakpoints here

to understand the flow of the code? There are several conditions there that could cause the button not to render.


Could you toss us a screenshot of where the button is missing from. Also let us know weather you have buttons shown within a list or next to each other (Option set within system settings)

There was a bug at one point that was fixed recently, would have assumed that it was within 22 but potentially not

I have tried to brakepoint in this file, but nothing happend.

Remove button is missing in every subpanel in every module.

HTML code above shows inspect of Edit button.

Ok, @fcorluka, ill ask you to re-read my comment, primarily the second part which says:

I’m asking for the screenshot as it will allow me to confirm if the issue that you are currently seeing is the same I’m thinking of.

here it is