Missing "pdf" extension for "Download PDF" section of Reports


I am facing a bug on the Reports module of SuiteCRM that causes generated PDF’s to be missing their .pdf file extension. CSV reports are running without any issues. I tried removing spaces from the report name, and I tried wrapping the name in “”. My eventual “fix” was to simply add “.pdf” to the end of my report name. But this isn’t an ideal solution. I’m posting here to see if anyone else has experienced this problem, and if so, how I might go about fixing it?

My environment is:

IIS 7.5
MySQL (latest)

Thanks in advance.

Hi I’m also experiencing this issue.

I’m running SuiteCRM 7.1.3. I have tried running the normal repair tools but haven’t found a solution for this issue yet.

Also, looking in the logs nothing is mentioned about reports.

All I get from the logs after activating Debug level reporting, opening a report and clicking on “Download PDF” is…

09/10/14 00:53:30 [3964][1][WARN] Image CreateAOR_Reports.gif not found
09/10/14 00:53:30 [3964][1][WARN] Image AOR_Reports.gif not found

Can someone kindly assist with this?

Hi guys,

Thanks for highlighting this. I’ll log as a bug and we will aim to address this in future releases.