missing admin reset user password button.


We have just upgraded from 7.7.9 tp 7.8.3, a user asked me to send him its credentials so I went to admin > users management and opened the user page.
in my mind there was a reset password button when expanding the action button but now there is only Edit, Reset users preferences and Reset home page.

note: Enable System-Generated Passwords Feature is enabled.

Am I right saying that this option was there in previous versions but is not present anymore ?

as a workaround i asked him to use the forget password link on login page and told him its username.


up :silly:


We also had this problem and was able to resolve the issue.

Is your domain using ssl (https)? If yes, make sure that in your config.php the “site_url” reflects https also.

Ex. ‘site_url’ => ‘https://domain.crm.com.au:443

After that, re-enable the “Enable System-Generated Passwords Feature” from the Password Management.

Then finally do a “Quick Repair and Rebuild”.

This fixed the issue from our end, hopefully it also does for you.

Thank you.



Thank you, yes using https, I’ll give a try.



Have you tried the steps and can you confirm that it worked for you?

I had this issue on version 7.10.5

haroldadalia your solution worked perfectly, for my scenario all I did was add the port number 443, I has already included the htttps:// prefix, which I understand may not be necessary.

Many Thanks


1 Like